dev-python/pytest: Disable hanging py3.5+ tests
authorMichał Górny <mgorny@gentoo.org>
Wed, 11 Jul 2018 17:42:49 +0000 (19:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 11 Jul 2018 22:11:19 +0000 (00:11 +0200)
dev-python/pytest/pytest-3.4.2.ebuild

index 9fb19f1d81bf1f85b46836dcf206c280cab9ebaa..ed3fc47c722fe6ee836640afa8e58e102b901fe1 100644 (file)
@@ -64,6 +64,11 @@ python_prepare_all() {
        sed -i -e 's:test_wrapped_getfuncargnames_patching:_&:' \
                testing/python/integration.py || die
 
+       # those tests appear to hang with python3.5+;  TODO: investigate why
+       sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
+               testing/test_terminal.py || die
+       sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
+
        distutils-r1_python_prepare_all
 }