dev-php/pecl-rrd: add PHP 7.4 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 29 Nov 2019 13:14:26 +0000 (14:14 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 29 Nov 2019 13:14:26 +0000 (14:14 +0100)
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild

index 19278bc6f6d82fa9a6c27250f2183f2ec34dd49a..16e4bc484026ca10119b35d94c4820107e20e528 100644 (file)
@@ -4,12 +4,12 @@
 EAPI="7"
 
 # Define 5.6 here to have the {I,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
 
 inherit php-ext-pecl-r3
 
 # But we really only build 7.0
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
 
 DESCRIPTION="RRDtool bindings for PHP"
 LICENSE="BSD"
@@ -20,11 +20,12 @@ DEPEND="
        php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
        php_targets_php7-2? ( net-analyzer/rrdtool[graph] )
        php_targets_php7-3? ( net-analyzer/rrdtool[graph] )
+       php_targets_php7-4? ( net-analyzer/rrdtool[graph] )
 "
 RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
 
 src_prepare() {
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
                php-ext-source-r3_src_prepare
        else
                default
@@ -32,21 +33,21 @@ src_prepare() {
 }
 
 src_configure() {
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
                local PHP_EXT_ECONF_ARGS=()
                php-ext-source-r3_src_configure
        fi
 }
 
 src_install() {
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
                php-ext-pecl-r3_src_install
        fi
 }
 
 src_test() {
        local slot
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
                for slot in $(php_get_slots); do
                        php_init_slot_env "${slot}"
                        # Prepare test data