dev-python/libvirt-python: remove 1.2.20 and 1.2.21 (bug #568870)
authorMatthias Maier <tamiko@gentoo.org>
Tue, 22 Dec 2015 06:12:19 +0000 (00:12 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 22 Dec 2015 06:15:46 +0000 (00:15 -0600)
This is a cleanup for CVE-2015-5313 bug 568870.

Gentoo-Bugs: 568870

Package-Manager: portage-2.2.26

dev-python/libvirt-python/Manifest
dev-python/libvirt-python/libvirt-python-1.2.19.ebuild [deleted file]
dev-python/libvirt-python/libvirt-python-1.2.20.ebuild [deleted file]

index 990e7f916980dfde529f410c4466ca4cd0247f7d..00f649956108436262e2e9d40cd26e43eb3e45b4 100644 (file)
@@ -1,4 +1,2 @@
 DIST libvirt-python-1.2.18.tar.gz 171009 SHA256 204535ef160c9d10600b5fc3417f00f382e74b137a85b33774b97eb36d8a3638 SHA512 bf9f246d8bc2e55dc0cdeb22901b2dd2858b058c0616a2d5db3ca4a700c3430c9cd1f904ec3090cab7c3db1d40195a6365fed3b7b18fbd1d975fdca5fa57ce29 WHIRLPOOL a1e684360341b896bd96d6a313320ddb7ad455c64e4d1577076713e4913c95d2bd6f9222a6ac45b735a33d8e7fff06b40327e298d21e214857db17c859fb4849
-DIST libvirt-python-1.2.19.tar.gz 172149 SHA256 88ab63b0c53e435bd2c6e8551805fe273353708efd4dfab908257dc5f37bec49 SHA512 670cc7af3fc5e67fa8daa8312278ecf81608ceddd34c40fc799e0c2836a5a8c3489186dee5ffcd806bf70840c1aa7b64178eef334f35c4bbe5fe21413b473d3b WHIRLPOOL 74e73e1dcabd0ed67988f34cd12c7ecc3d71e5dbfc4a5f81f22e3aeed37ee3fa343b780bbafa7941a79abffdb4d7a566e65b73c185c695567d6558e18ef58b32
-DIST libvirt-python-1.2.20.tar.gz 170437 SHA256 e1ea097546edc7cb0e7fd01e2ca9906ac12cc4f16d07f15f8f0f5154626ba446 SHA512 2fd642b1f7efee46331636098e8bc9d1194f399bb93e9d445103a70264332bb6b216bb42846432707e1538f73f96c4c141dde84779d3b36cc93f6f7914466ef9 WHIRLPOOL 19c56d69a8c61814b8312e5b0920efae6433bffe3cd33237a34efb6847abd4bafa686481cd40c72cc0f92290d0c70efc53d83c42d2b6a2f20928608321c41351
 DIST libvirt-python-1.2.21.tar.gz 171250 SHA256 7ffb49fcb64ac06188fc626c853c99361e5965766ab020f8ea66f8fbcfc29684 SHA512 7e2481ffa26105ddde703bd6eafe74240b69990b2f2ce0042f20f7fceb1d326fb8a66bf26042bfe63a12cf3202d7c19b14b6d766dd42fb66af212393d7aaf332 WHIRLPOOL 18dd5bc0d565b6846c40960cf258d7fb3714054be15fe54507e2846c5a7c2cd81e9b209c8e70cbfd5319d5a06f00c2c5322995058637af87d1676276f8675b2e
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.19.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.19.ebuild
deleted file mode 100644 (file)
index cc59d1b..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-AUTOTOOLIZE=yes
-
-MY_P="${P/_rc/-rc}"
-
-inherit eutils distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
-       SRC_URI=""
-       KEYWORDS=""
-       RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
-       SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-       RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="http://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="test"
-
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       test? ( dev-python/lxml[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-# testsuite is currently not included in upstream tarball
-RESTRICT="test"
-
-python_test() {
-       esetup.py test
-}
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.20.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.20.ebuild
deleted file mode 100644 (file)
index cc59d1b..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-AUTOTOOLIZE=yes
-
-MY_P="${P/_rc/-rc}"
-
-inherit eutils distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
-       SRC_URI=""
-       KEYWORDS=""
-       RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
-       SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-       RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="http://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="test"
-
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       test? ( dev-python/lxml[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-# testsuite is currently not included in upstream tarball
-RESTRICT="test"
-
-python_test() {
-       esetup.py test
-}