dev-perl/Crypt-Random: Bump to version 1.520.0 re bug #625654
authorKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 09:08:10 +0000 (21:08 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 09:09:42 +0000 (21:09 +1200)
- Convert to EAPI6
- Enable parallel tests

Upstream:
- Add Uniform parameter to Crypt::Random::Generator constructor
- Removed test for non-equality of 2 randomly generated ints
- Removed /dev/random entropy-blocking test
- Removed potentially unsafe include in makerandom

Bug: https://bugs.gentoo.org/625654
Bug: https://rt.cpan.org/Ticket/Display.html?id=30423
Bug: https://rt.cpan.org/Ticket/Display.html?id=99880
Bug: https://rt.cpan.org/Ticket/Display.html?id=128062
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Crypt-Random/Crypt-Random-1.520.0.ebuild [new file with mode: 0644]
dev-perl/Crypt-Random/Manifest

diff --git a/dev-perl/Crypt-Random/Crypt-Random-1.520.0.ebuild b/dev-perl/Crypt-Random/Crypt-Random-1.520.0.ebuild
new file mode 100644 (file)
index 0000000..ff21ac2
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=VIPUL
+DIST_VERSION=1.52
+inherit perl-module
+
+DESCRIPTION="Cryptographically Secure, True Random Number Generator"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+       >=dev-perl/Math-Pari-2.1.804
+       >=dev-perl/Class-Loader-2.0.0
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+"
index c8dd26dbcccee2467d0b32757879ba8f1faa74cf..974869c28dc5a25239709bd0056c403246735f4b 100644 (file)
@@ -1 +1,2 @@
 DIST Crypt-Random-1.25.tar.gz 8770 BLAKE2B 4c6b20711e8d455b3de4061ba60b05ac9f35c8df9b193be955f5af780deb91116404242a5789f807c77d398459343322dce9346377aee9049a7314ac5731b423 SHA512 6c62e64a46d31aa7ef9caecb4e4535bfded9c62fc5156bc9c6390a019ea5d29772bcb1029889b111af6727d756d00ce0cc9407fc50ba7a31941d921c43df5fb7
+DIST Crypt-Random-1.52.tar.gz 9525 BLAKE2B febe32d8b3c4a903220073bd591cbc09f6e6c5e1919e2ae825f5e4d63f68577fccd6e1adf1878b940e8a2af5af044e56cd79e0d49b4717785be0b5ffbe74fefb SHA512 b82252aae6a009b0dc09bf2e6704d114cd4e40b9588269246871d3b1fb66b4abda87e7c324afc30fd9cf19eb0c0502c2af05d8981226513223277f83854b770f