net-vpn/tinc: Fix compiling against sys-libs/ncurses[tinfo] (bug #621868).
authorJeroen Roovers <jer@gentoo.org>
Sun, 25 Feb 2018 20:57:48 +0000 (21:57 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 25 Feb 2018 20:58:45 +0000 (21:58 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-vpn/tinc/files/tinc-1.1-tinfo.patch [new file with mode: 0644]
net-vpn/tinc/tinc-1.1_pre15.ebuild

diff --git a/net-vpn/tinc/files/tinc-1.1-tinfo.patch b/net-vpn/tinc/files/tinc-1.1-tinfo.patch
new file mode 100644 (file)
index 0000000..5a9ec01
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/m4/curses.m4
++++ b/m4/curses.m4
+@@ -39,6 +39,7 @@
+       )]
+     )
+   ])
++  AC_SEARCH_LIBS(stdscr, tinfo)
+   AC_SUBST(CURSES_LIBS)
+ ])
index a1b29bd7546336bd16391f2b7452e2a0917978cc..57d5cee18286b42e77ead2a34e4a48e8b1016ddc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -8,7 +8,7 @@ MY_P=${PN}-${MY_PV}
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit eutils multilib python-single-r1 systemd
+inherit autotools multilib python-single-r1 systemd
 
 DESCRIPTION="tinc is an easy to configure VPN implementation"
 HOMEPAGE="http://www.tinc-vpn.org/"
@@ -41,7 +41,6 @@ DEPEND="
        zlib? ( sys-libs/zlib )"
 RDEPEND="${DEPEND}
        vde? ( net-misc/vde )"
-
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
@@ -55,7 +54,10 @@ src_prepare() {
        fi
 
        eapply "${FILESDIR}"/tinc-1.1-fix-paths.patch #560528
+       eapply "${FILESDIR}"/${PN}-1.1-tinfo.patch #621868
        eapply_user
+
+       eautoreconf
 }
 
 src_configure() {