net-dns/dnscrypt-proxy: bump to 2.0.32
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 18 Nov 2019 19:52:41 +0000 (11:52 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 18 Nov 2019 19:52:41 +0000 (11:52 -0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-dns/dnscrypt-proxy/Manifest
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.32.ebuild [new file with mode: 0644]

index 4fb0ec3f25cf14e64c4e13b2c5ae709cfedea2a2..acde3df1648e32030ad9889c9ea260c515d3b31e 100644 (file)
@@ -4,3 +4,4 @@ DIST dnscrypt-proxy-2.0.27.tar.gz 2478887 BLAKE2B e9cabd6bdb330c3174cb904951f9e1
 DIST dnscrypt-proxy-2.0.28.tar.gz 2620245 BLAKE2B fe31dd6d8054c4ae3d5892aaef0c8362405e06dba6de32121d9dea5d64d396ec39b1cfa884d5587c21367bb1dc3c1a4b4f994c286d0b8cc2a8bdbd9d247d239e SHA512 45496a02bd19c94def17b621d0843cc93de4467e51ded4c20af91d9b5aa127529d85b8ff2473a88293c726611291a055d466a50258b7587da0e7d4ba7f0f366e
 DIST dnscrypt-proxy-2.0.29.tar.gz 2621844 BLAKE2B 3ebd02b3c9df9dcb41d27d38a9d9f64c01d98f7b1afee7a7c3b1dd3ef26b2104aae650e34ff1b5651007461ee75d28bcfbfa3c7e82c32532f36553740e3dcb50 SHA512 f02abe56e017153e7fc8b4a26b34c90f68554a1b32a16558c05e8113327896dbf7f81aa69c76fa823a4a0a697b4bb2089bdeb1237ad4ef3587121c2d4cdfe78c
 DIST dnscrypt-proxy-2.0.31.tar.gz 2640523 BLAKE2B cf2e2b5557e6fcf59d3d28978db6c5e46f6b7f58aa4c5ae423149ec2f557269e88846dc4f97c6f6f20ff013b14b61b20d2df750d6b07946606293778a31e0ca1 SHA512 500c800213b94bf8ecbea7493716de5fe41afd584c70844519f1f50827b94a28ec982f2c2b85f7a281dca58273ba968113beed6a965c62bb3dc47ab83d7a1629
+DIST dnscrypt-proxy-2.0.32.tar.gz 2722700 BLAKE2B 858fcc20d1466104e387d5f6ea9f93a08976d4a98c7cf80ccee922d7b89749e5b88d487c08d300e0eab759abc4a97d0337146b397e0301465726fe5b06bcb915 SHA512 faceca394d793a78c3c9b71b99492953c77857a071e48ad163b3624322f5321e0185da055000508588507a4d2fe76afe2407a56db83c637565ce119c91827cc4
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.32.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.32.ebuild
new file mode 100644 (file)
index 0000000..215c072
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+       SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+
+LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="pie"
+
+DEPEND=">=dev-lang/go-1.12"
+
+RDEPEND="
+       acct-group/dnscrypt-proxy
+       acct-user/dnscrypt-proxy
+"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+src_prepare() {
+       default
+       # Create directory structure suitable for building
+       mkdir -p "src/${EGO_PN%/*}" || die
+       # fixes $GOPATH/go.mod exists but should not
+       rm go.mod || die
+       mv "${PN}" "src/${EGO_PN}" || die
+       mv "vendor" "src/${EGO_PN}" || die
+}
+
+src_configure() {
+       EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
+}
+
+src_install() {
+       dobin dnscrypt-proxy
+
+       insinto /etc/dnscrypt-proxy
+       newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+       doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+       doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+       insinto /usr/share/dnscrypt-proxy
+       doins -r "utils/generate-domains-blacklists/."
+
+       newinitd "${FILESDIR}"/dnscrypt-proxy.initd-r1 dnscrypt-proxy
+       newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       fcaps_pkg_postinst
+
+       if ! use filecaps; then
+               ewarn "'filecaps' USE flag is disabled"
+               ewarn "${PN} will fail to listen on port 53"
+               ewarn "please do one the following:"
+               ewarn "1) re-enable 'filecaps'"
+               ewarn "2) change port to > 1024"
+               ewarn "3) configure to run ${PN} as root (not recommended)"
+               ewarn
+       fi
+
+       if systemd_is_booted || has_version sys-apps/systemd; then
+               elog "Using systemd socket activation may cause issues with speed"
+               elog "latency and reliability of ${PN} and is discouraged by upstream"
+               elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+               elog "It is disabled by default for new installations"
+               elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+               elog
+
+       fi
+
+       elog "After starting the service you will need to update your"
+       elog "/etc/resolv.conf and replace your current set of resolvers"
+       elog "with:"
+       elog
+       elog "nameserver 127.0.0.1"
+       elog
+       elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}