dev-ros/filters: Backport upstream fix to build without rostest when tests are not...
authorAlexis Ballier <aballier@gentoo.org>
Wed, 7 Oct 2015 10:47:58 +0000 (12:47 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 7 Oct 2015 10:48:09 +0000 (12:48 +0200)
Package-Manager: portage-2.2.22

dev-ros/filters/files/rostest.patch [new file with mode: 0644]
dev-ros/filters/filters-1.7.4.ebuild

diff --git a/dev-ros/filters/files/rostest.patch b/dev-ros/filters/files/rostest.patch
new file mode 100644 (file)
index 0000000..6a266fd
--- /dev/null
@@ -0,0 +1,27 @@
+commit 5aef0d6619394df17bffe743071295ad041b5794
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date:   Tue Feb 4 16:02:09 2014 +0100
+
+    make rostest in CMakeLists optional (ros/rosdistro#3010)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ccb54f9..97eea51 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,7 @@ project(filters)
+ # Find dependencies
+ ##############################################################################
+-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
++find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
+ find_package(Boost COMPONENTS system filesystem thread REQUIRED)
+ include_directories(
+@@ -41,6 +41,7 @@ add_library(transfer_function src/transfer_function.cpp)
+ target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+ if(CATKIN_ENABLE_TESTING)
++  find_package(rostest)
+ # Test median filter
+ add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
+ target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES}) 
index 4b50ee0a04978fe86b80e191fec372d466baa26d..d718f2d4a9f9f33f502c702173fcbd40d982d4e1 100644 (file)
@@ -18,4 +18,4 @@ RDEPEND="dev-ros/roscpp
        dev-ros/pluginlib"
 DEPEND="${RDEPEND}
        test? ( dev-ros/rostest dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/tests.patch" )
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/rostest.patch" )