media-libs/gd: Minor code beautification.
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 7 Aug 2017 06:54:24 +0000 (08:54 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 7 Aug 2017 06:55:39 +0000 (08:55 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

media-libs/gd/gd-2.2.4.ebuild

index d1305fbd5ba03a40ce30ccd7a55ac24109f6dbd3..7cdcb905a456ddd9d04573901a9c6090fdefe8d6 100644 (file)
@@ -39,20 +39,21 @@ multilib_src_configure() {
        # we aren't actually {en,dis}abling X here ... the configure
        # script uses it just to add explicit -I/-L paths which we
        # don't care about on Gentoo systems.
-       ECONF_SOURCE=${S} \
-       econf \
-               --disable-werror \
-               --without-x \
-               --without-liq \
-               $(use_enable static-libs static) \
-               $(use_with fontconfig) \
-               $(use_with png) \
-               $(use_with tiff) \
-               $(use_with truetype freetype) \
-               $(use_with jpeg) \
-               $(use_with webp) \
-               $(use_with xpm) \
+       local myeconfargs=(
+               --disable-werror
+               --without-x
+               --without-liq
+               $(use_enable static-libs static)
+               $(use_with fontconfig)
+               $(use_with png)
+               $(use_with tiff)
+               $(use_with truetype freetype)
+               $(use_with jpeg)
+               $(use_with webp)
+               $(use_with xpm)
                $(use_with zlib)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
 }
 
 multilib_src_install_all() {