sci-libs/ta-lib: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:29 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:29 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-libs/ta-lib/ta-lib-0.4.0.ebuild

index 99cb7258bb33cca37660e58dccc62aa4037ef2e4..7a7a581a503cabad4c726821ba240c9fc12bc573 100644 (file)
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils
+inherit autotools
 
 DESCRIPTION="Technical Analysis Library for analyzing financial markets trends"
 HOMEPAGE="http://www.ta-lib.org/"
@@ -14,15 +12,28 @@ SRC_URI="mirror://sourceforge/ta-lib/${P}-src.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
 
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
 
 PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
 
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+       default
+       mv configure.{in,ac} || die
+       eautoreconf
+}
+
+src_configure() {
+       econf --disable-static
+}
 
 src_test() {
-       ewarn "Note: this testsuite will fail without an active internet connection."
-       "${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."
+       src/tools/ta_regtest/ta_regtest || die
+}
+
+src_install() {
+       default
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }