dev-python/logbook: 1.4.0
authorSebastian Pipping <sping@gentoo.org>
Wed, 15 Aug 2018 14:01:22 +0000 (16:01 +0200)
committerSebastian Pipping <sping@gentoo.org>
Wed, 15 Aug 2018 14:03:18 +0000 (16:03 +0200)
Also fix patch to support EAPI 6.

Bug: https://bugs.gentoo.org/661594
Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-python/logbook/Manifest
dev-python/logbook/files/logbook-0.4.2-objectsinv.patch
dev-python/logbook/logbook-1.4.0.ebuild [new file with mode: 0644]

index f619052476082343bdefde84cba17e5db4864822..ca98c6c31451f183abfd3f8beb9164af9b5275ac 100644 (file)
@@ -1,2 +1,3 @@
 DIST logbook-0.9.1.tar.gz 106615 BLAKE2B 4100bda341a1c946bbabfb6ff423b4906f0ada754ebcbaefca93d768bd8c5135a9b1e00207fba4b13ce297cb7eca27364000e9f8b9f52935608af6c9586302aa SHA512 d136dd5a7219a23a50db857919d794e7b721cc629443ac2bf92374aef68889d8a7146886fc4484c6d0dea56ec5c1c1ccca3f0b20310c2e12dba9d40dcac9c188
 DIST logbook-1.1.0.tar.gz 367541 BLAKE2B 26e27e94f1238c9188fc66b6eb1f5622d96e1c0db97817dba30c8c70107544ea80ab1f11b71592db6a8e2a9c5d32dd659782a532cb7d263c2f042b41ef88d2ad SHA512 55ec7a026a08baed405e29d7cdcc9d3cc423c9faf13788c2447ac7ccff688de9bd9e332ad78077b1eef8bc8ad9aea572f9c124888f46ecabc2abf22d8ac9086b
+DIST logbook-1.4.0.tar.gz 369335 BLAKE2B 02398be49d2a12aadbcde90561afe6ac08060877922fa04b27f08587115aef8faf47bfc352fc005b8a986ab619289c8544fe53a84e0e863a09c992685f78739c SHA512 3ea969e9e2075e34a915566be906266b408671657e4cecbe47663c28f2212c0522b0f0eb2832fbc4fb906f70c8e53d3cdbe65923dafe53a77545b8126ab539f2
index 28b26f0bc9a37780b92c17c0344cf9832068a4e6..2575f862eded279015d17fc10d0ada86c1b0f829 100644 (file)
@@ -1,7 +1,7 @@
 Prevent unwanted d'loading of un-needed objects.inv files
 diff -ur logbook-0.4.2.orig/docs/conf.py logbook-0.4.2/docs/conf.py
---- docs/conf.py       2013-06-02 19:31:32.000000000 +0800
-+++ docs/conf.py       2013-06-30 10:50:38.604402792 +0800
+--- logbook-0.4.2/docs/conf.py 2013-06-02 19:31:32.000000000 +0800
++++ logbook-0.4.2/docs/conf.py 2013-06-30 10:50:38.604402792 +0800
 @@ -219,6 +219,3 @@
       [u'Armin Ronacher, Georg Brandl'], 1)
  ]
diff --git a/dev-python/logbook/logbook-1.4.0.ebuild b/dev-python/logbook/logbook-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..72ffa78
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="https://logbook.readthedocs.io/en/stable/
+       https://github.com/getlogbook/logbook
+       https://pypi.org/project/Logbook/"
+SRC_URI="https://github.com/getlogbook/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+       doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_prepare_all() {
+       # Delete test file requiring local connection to redis server
+       rm tests/test_queues.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       py.test tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}