net-mail/notmuch: Bump to 0.29.3
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Wed, 27 Nov 2019 23:10:29 +0000 (23:10 +0000)
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Wed, 27 Nov 2019 23:11:53 +0000 (23:11 +0000)
Remove 0.29.2-r1 as 0.29.3 has the backported patch and one more
additional fix.

Bug: https://bugs.gentoo.org/701350
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
net-mail/notmuch/Manifest
net-mail/notmuch/files/0.29.2-0001-notmuch-dump.c-Fix-output-file-being-closed-twice.patch [deleted file]
net-mail/notmuch/files/0.29.3-0001-Use-loopback-IP-address-rather-than-name.patch [new file with mode: 0644]
net-mail/notmuch/notmuch-0.29.3.ebuild [moved from net-mail/notmuch/notmuch-0.29.2-r1.ebuild with 98% similarity]

index fdfe821babee7c1fea433d28086f8252f8c28e2d..8dc7ed2328624bf1b9437fd24baf5a85f7aaa54a 100644 (file)
@@ -1,3 +1,4 @@
 DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b4046772058706f13d516f65421a5105593660f1c556907bb2bb9607a3c2521243d1be07bffb70817ad3b8461680ca SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0
 DIST notmuch-0.28.4.tar.gz 922364 BLAKE2B f22d52ecc982b086b5d2a67d3b9ae4a379bdcb9e9acf3e77060fd7d97439347e3b4cd767f2c9c3c48657b80f63316f6abc09a653d6791e27b4a8996adccf42a9 SHA512 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
 DIST notmuch-0.29.2.tar.xz 660520 BLAKE2B f87889db5fa1049b2b91a9ea8abe917e5645860a5c163c73a57197ede904aa335c0f3b37cc2a7ff2465c30e94eb25b113bebd074aa9e92c84383457600e1de82 SHA512 0e345c4ecca8410eedb14154bcb3c327353a0984f30b7fd6c526deefcfe17aa74ca8fb4b4d28e93decca8c8914f7d60ca2c9485750001b14d67d7d33d4721bb3
+DIST notmuch-0.29.3.tar.xz 660536 BLAKE2B bd5d62eba06102acbc0615cd97ac9ff5578c1f68d50b24a79ea9fb1ea77850d84e0713fb648cb04e74a61ac3321ea5ef82db714786adf38ea10d00c5846decff SHA512 b1e0b47ebf2d2de0ccd39976782eb8a7b417e36f2f9d78ef19e27e55719a02ee919508843a0eaf258f58138914ab2e8796d2fc1782b9cfe2d8937abb6184be65
diff --git a/net-mail/notmuch/files/0.29.2-0001-notmuch-dump.c-Fix-output-file-being-closed-twice.patch b/net-mail/notmuch/files/0.29.2-0001-notmuch-dump.c-Fix-output-file-being-closed-twice.patch
deleted file mode 100644 (file)
index cafef61..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/notmuch-dump.c   2019-07-24 17:11:02.899384482 +0200
-+++ b/notmuch-dump.c   2019-07-24 17:12:08.100487117 +0200
-@@ -329,13 +329,15 @@
-       }
-     }
--    if (gzclose_w (output) != Z_OK) {
-+    ret = gzclose_w (output);
-+    if (ret) {
-       fprintf (stderr, "Error closing %s: %s\n", name_for_error,
-                gzerror (output, NULL));
-       ret = EXIT_FAILURE;
-       output = NULL;
-       goto DONE;
--    }
-+    } else
-+        output = NULL;
-     if (output_file_name) {
-       ret = rename (tempname, output_file_name);
diff --git a/net-mail/notmuch/files/0.29.3-0001-Use-loopback-IP-address-rather-than-name.patch b/net-mail/notmuch/files/0.29.3-0001-Use-loopback-IP-address-rather-than-name.patch
new file mode 100644 (file)
index 0000000..e472246
--- /dev/null
@@ -0,0 +1,61 @@
+From 59b5bfb6e2095c62925b31e087571506edae7956 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20Piotr=20=C5=BBo=C5=82nowski?=
+ <aidecoe@aidecoe.name>
+Date: Sun, 7 Jul 2019 11:33:09 +0100
+Subject: [PATCH] Use loopback IP address rather than name
+
+---
+ test/smtp-dummy.c | 8 ++++----
+ test/test-lib.sh  | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/smtp-dummy.c b/test/smtp-dummy.c
+index a7c1fe4f..822a986a 100644
+--- a/test/smtp-dummy.c
++++ b/test/smtp-dummy.c
+@@ -76,7 +76,7 @@ process_command (FILE *peer, FILE *output, const char *command)
+       fprintf (peer, "502 not implemented\r\n");
+       fflush (peer);
+     } else if (STRNCMP_LITERAL (command, "HELO ") == 0) {
+-      fprintf (peer, "250 localhost\r\n");
++      fprintf (peer, "250 127.0.0.1\r\n");
+       fflush (peer);
+     } else if (STRNCMP_LITERAL (command, "MAIL FROM:") == 0 ||
+              STRNCMP_LITERAL (command, "RCPT TO:") == 0) {
+@@ -105,7 +105,7 @@ do_smtp_to_file (FILE *peer, FILE *output)
+     size_t line_size;
+     ssize_t line_len;
+-    fprintf (peer, "220 localhost smtp-dummy\r\n");
++    fprintf (peer, "220 127.0.0.1 smtp-dummy\r\n");
+     fflush (peer);
+     while ((line_len = getline (&line, &line_size, peer)) != -1) {
+@@ -183,9 +183,9 @@ main (int argc, char *argv[])
+       goto DONE;
+     }
+-    hostinfo = gethostbyname ("localhost");
++    hostinfo = gethostbyname ("127.0.0.1");
+     if (hostinfo == NULL) {
+-      fprintf (stderr, "Unknown host: localhost\n");
++      fprintf (stderr, "Unknown host: 127.0.0.1\n");
+       ret = 1;
+       goto DONE;
+     }
+diff --git a/test/test-lib.sh b/test/test-lib.sh
+index 616cb674..dd887773 100644
+--- a/test/test-lib.sh
++++ b/test/test-lib.sh
+@@ -336,7 +336,7 @@ emacs_deliver_message ()
+     test_emacs \
+       "(let ((message-send-mail-function 'message-smtpmail-send-it)
+              (mail-host-address \"example.com\")
+-             (smtpmail-smtp-server \"localhost\")
++             (smtpmail-smtp-server \"127.0.0.1\")
+              (smtpmail-smtp-service \"${smtp_dummy_port}\"))
+          (notmuch-mua-mail)
+          (message-goto-to)
+-- 
+2.19.2
+
similarity index 98%
rename from net-mail/notmuch/notmuch-0.29.2-r1.ebuild
rename to net-mail/notmuch/notmuch-0.29.3.ebuild
index 6edb84f72d20745585e583d8c23d437553fa8406..e845830282d82b47191e32c8131997985000a528 100644 (file)
@@ -76,7 +76,6 @@ SITEFILE="50${PN}-gentoo.el"
 MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
 PATCHES=(
        "${FILESDIR}"/${PV}-0001-Use-loopback-IP-address-rather-than-name.patch
-       "${FILESDIR}"/${PV}-0001-notmuch-dump.c-Fix-output-file-being-closed-twice.patch
 )
 
 bindings() {