dev-libs/libksba: eapi bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 5 Oct 2018 19:03:25 +0000 (22:03 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 5 Oct 2018 19:26:11 +0000 (22:26 +0300)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
dev-libs/libksba/libksba-1.3.5-r2.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libksba/libksba-1.3.5-r2.ebuild b/dev-libs/libksba/libksba-1.3.5-r2.ebuild
new file mode 100644 (file)
index 0000000..b8c1d0e
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="X.509 and CMS (PKCS#7) library"
+HOMEPAGE="http://www.gnupg.org/related_software/libksba"
+SRC_URI="mirror://gnupg/libksba/${P}.tar.bz2"
+
+LICENSE="LGPL-3+ GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       # ppl need to use lib*-config for --cflags and --libs
+       find "${D}" -name '*.la' -delete || die
+}