sys-cluster/ceph: Version bump to 14.2.4, drop x86 (bug 687344)
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 17 Sep 2019 22:55:07 +0000 (15:55 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 17 Sep 2019 22:55:52 +0000 (15:55 -0700)
Dropped x86 keyword since it doesn't build (bug #687344)

Upstream fix for bug #694140 included in release

Closes: https://bugs.gentoo.org/687344
Closes: https://bugs.gentoo.org/694140
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-cluster/ceph/Manifest
sys-cluster/ceph/ceph-14.2.4.ebuild [new file with mode: 0644]
sys-cluster/ceph/files/ceph-14.2.3-dpdk-compile-fix-1.patch [new file with mode: 0644]

index 0655ed2e6b615acc98d081c86946efa7562dcd33..b1f4c19693622d3ed0963da4fde3061849e38368 100644 (file)
@@ -4,3 +4,4 @@ DIST ceph-12.2.8.tar.gz 77243685 BLAKE2B 37c34396a0c276b8d79735e14934ac70da02482
 DIST ceph-13.2.5.tar.gz 91006057 BLAKE2B 68551e2f54d78aff7b0e9ec3c62e6a3394dd7c23e80924a5b400cd9666a05a42e5f22445deee4040f1b78201c6a6660b283109878d4c92d845821bff831c8a5e SHA512 6daea524523f829e725609328ea71f416b2c3a9530fa8956720a7bc69dc08e55a169654f500704579dc9ba693f04eedd7e04614c0850e9ab1169cd45f19039f8
 DIST ceph-13.2.6.tar.gz 90808224 BLAKE2B cd7b4f4838eafc9dd580102cbb5247b86a153f90127f81355b556f32dbbacd2d7fb0144d15f99869a318a7148d2f50a9f995eb05aee056d7a5843830ede5702c SHA512 1e9c08d16b14447bf6b8bb72144e053aa9d5cf390bb4a6e878869e38895d3698073502fe9c4f8b775a3da872b920444bd01260105d3a839e53cf90cd27c6ab9c
 DIST ceph-14.2.3.tar.gz 118349530 BLAKE2B db73d6adeca84426eee1b47a8ee68c4f94ee7a61e60ef1127153d19e02472a658877ebb7adfad5b4725d2c8c38855636bad1c44e79a3d3c397b56f74bf4b53fa SHA512 3d02e766a1d53d39355ee88738dd0233dc02f8a3cb44935194cb538b888507de8f8acdd99bf7890895f68795a310f53e2a8652305d5f2be5212efbd9046bd3a9
+DIST ceph-14.2.4.tar.gz 116371380 BLAKE2B 2d2c78ec32a0749df16e9c527d2fd087a75daeb2ef26ac5f6aa641989eab62fa276eb320b873740e9eee3fd4f369da152c53c2389b1def1b6a45906ccc1bd1f1 SHA512 dc60321ed4dcaccacca711ab70c35011b5dfc6b8369016fb413a9976199ed4ba22c7dc87ba1ebaf1118513dee1a0c263c99ab137f27fc03c55e8a0625a3bdcc0
diff --git a/sys-cluster/ceph/ceph-14.2.4.ebuild b/sys-cluster/ceph/ceph-14.2.4.ebuild
new file mode 100644 (file)
index 0000000..82af9e6
--- /dev/null
@@ -0,0 +1,356 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+DISTUTILS_OPTIONAL=1
+
+inherit check-reqs bash-completion-r1 cmake-utils distutils-r1 flag-o-matic \
+               multiprocessing python-r1 udev user readme.gentoo-r1 toolchain-funcs \
+               systemd
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ceph/ceph.git"
+       SRC_URI=""
+else
+       SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64"
+fi
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="https://ceph.com/"
+
+LICENSE="LGPL-2.1 CC-BY-SA-3.0 GPL-2 GPL-2+ LGPL-2+ BSD Boost-1.0 MIT public-domain"
+SLOT="0"
+
+CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
+
+IUSE="babeltrace cephfs dpdk fuse grafana jemalloc kerberos ldap libressl"
+IUSE+=" lttng +mgr numa rabbitmq +radosgw +ssl static-libs system-boost"
+IUSE+=" systemd +tcmalloc test xfs zfs"
+IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
+
+COMMON_DEPEND="
+       virtual/libudev:=
+       app-arch/bzip2:=[static-libs?]
+       app-arch/lz4:=[static-libs?]
+       app-arch/snappy:=[static-libs?]
+       app-arch/zstd:=[static-libs?]
+       app-misc/jq:=[static-libs?]
+       dev-libs/crypto++:=[static-libs?]
+       dev-libs/leveldb:=[snappy,static-libs?,tcmalloc?]
+       dev-libs/libaio:=[static-libs?]
+       dev-libs/libxml2:=[static-libs?]
+       dev-libs/nss:=
+       sys-auth/oath-toolkit:=
+       sys-apps/keyutils:=[static-libs?]
+       sys-apps/util-linux:=[static-libs?]
+       sys-libs/ncurses:0=[static-libs?]
+       sys-libs/zlib:=[static-libs?]
+       babeltrace? ( dev-util/babeltrace )
+       ldap? ( net-nds/openldap:=[static-libs?] )
+       lttng? ( dev-util/lttng-ust:= )
+       fuse? ( sys-fs/fuse:0=[static-libs?] )
+       kerberos? ( virtual/krb5 )
+       rabbitmq? ( net-libs/rabbitmq-c:=[static-libs?] )
+       ssl? (
+               !libressl? ( dev-libs/openssl:=[static-libs?] )
+               libressl? ( dev-libs/libressl:=[static-libs?] )
+       )
+       xfs? ( sys-fs/xfsprogs:=[static-libs?] )
+       zfs? ( sys-fs/zfs:=[static-libs?] )
+       radosgw? (
+               dev-libs/expat:=[static-libs?]
+               !libressl? (
+                       dev-libs/openssl:=[static-libs?]
+                       net-misc/curl:=[curl_ssl_openssl,static-libs?]
+               )
+               libressl? (
+                       dev-libs/libressl:=[static-libs?]
+                       net-misc/curl:=[curl_ssl_libressl,static-libs?]
+               )
+       )
+       system-boost? (
+               || (
+                       ~dev-libs/boost-1.70.0[threads,context,python,static-libs?,${PYTHON_USEDEP}]
+                       ~dev-libs/boost-1.67.0[threads,context,python,static-libs?,${PYTHON_USEDEP}]
+               )
+               dev-libs/boost:=[threads,context,python,static-libs?,${PYTHON_USEDEP}]
+       )
+       jemalloc? ( dev-libs/jemalloc:=[static-libs?] )
+       !jemalloc? ( >=dev-util/google-perftools-2.4:=[static-libs?] )
+       ${PYTHON_DEPS}
+       "
+DEPEND="${COMMON_DEPEND}
+       amd64? ( dev-lang/yasm )
+       x86? ( dev-lang/yasm )
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/sphinx
+       dev-util/cunit
+       test? (
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/virtualenv[${PYTHON_USEDEP}]
+               sys-apps/grep[pcre]
+               sys-fs/btrfs-progs
+       )
+       "
+BDEPEND="      app-arch/cpio
+       >=dev-util/cmake-3.5.0
+       dev-util/gperf
+       dev-util/valgrind
+       sys-apps/which
+       sys-devel/bc
+       virtual/pkgconfig
+       "
+RDEPEND="${COMMON_DEPEND}
+       net-misc/socat
+       sys-apps/gptfdisk
+       sys-block/parted
+       sys-fs/cryptsetup
+       sys-fs/lvm2[-device-mapper-only(-)]
+       !<sys-apps/openrc-0.26.3
+       dev-python/bcrypt[${PYTHON_USEDEP}]
+       dev-python/cherrypy[${PYTHON_USEDEP}]
+       dev-python/flask[${PYTHON_USEDEP}]
+       dev-python/jinja[${PYTHON_USEDEP}]
+       dev-python/pecan[${PYTHON_USEDEP}]
+       dev-python/prettytable[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/werkzeug[${PYTHON_USEDEP}]
+       "
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       || ( $(python_gen_useflags 'python3*') )
+       ?? ( jemalloc tcmalloc )
+       rabbitmq? ( radosgw )
+       "
+
+# the tests need root access
+RESTRICT="test? ( userpriv )"
+
+# distribution tarball does not include everything needed for tests
+RESTRICT+=" test"
+
+# false positives unless all USE flags are on
+CMAKE_WARN_UNUSED_CLI="no"
+
+UNBUNDLE_LIBS=(
+       src/erasure-code/jerasure/jerasure
+       src/erasure-code/jerasure/gf-complete
+)
+
+PATCHES=(
+       "${FILESDIR}/ceph-12.2.0-use-provided-cpu-flag-values.patch"
+       "${FILESDIR}/ceph-14.2.0-cflags.patch"
+       "${FILESDIR}/ceph-12.2.4-boost-build-none-options.patch"
+       "${FILESDIR}/ceph-13.2.0-cflags.patch"
+       "${FILESDIR}/ceph-14.2.0-mgr-python-version.patch"
+       "${FILESDIR}/ceph-14.2.0-no-virtualenvs.patch"
+       "${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
+       "${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
+       "${FILESDIR}/ceph-14.2.0-link-crc32-statically.patch"
+       "${FILESDIR}/ceph-14.2.0-cython-0.29.patch"
+       "${FILESDIR}/ceph-14.2.3-boost-1.70.patch"
+       "${FILESDIR}/ceph-14.2.3-dpdk-compile-fix-1.patch"
+)
+
+# dpdk and ninja don't get along
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+check-reqs_export_vars() {
+       if use amd64; then
+               CHECKREQS_DISK_BUILD="12G"
+               CHECKREQS_DISK_USR="460M"
+       else
+               CHECKREQS_DISK_BUILD="1400M"
+               CHECKREQS_DISK_USR="450M"
+       fi
+
+       export CHECKREQS_DISK_BUILD CHECKREQS_DISK_USR
+}
+
+user_setup() {
+       enewgroup ceph ${CEPH_GID}
+       enewuser ceph "${CEPH_UID:--1}" -1 /var/lib/ceph ceph
+}
+
+pkg_pretend() {
+       check-reqs_export_vars
+       check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+       python_setup 'python3*'
+       check-reqs_export_vars
+       check-reqs_pkg_setup
+       user_setup
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       if use system-boost; then
+               eapply "${FILESDIR}/ceph-14.2.3-boost-sonames.patch"
+
+               has_version '>=dev-libs/boost-1.70.0' || \
+                       eapply "${FILESDIR}/ceph-14.2.3-boost-1.6-python-sonames.patch"
+       fi
+
+       sed -i -r "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \
+               src/bash_completion/CMakeLists.txt || die
+
+       # remove tests that need root access
+       rm src/test/cli/ceph-authtool/cap*.t || die
+}
+
+ceph_src_configure() {
+       local flag
+       local mycmakeargs=(
+               -DWITH_BABELTRACE=$(usex babeltrace)
+               -DWITH_CEPHFS=$(usex cephfs)
+               -DWITH_CEPHFS_SHELL=$(if python_is_python3; then usex cephfs; else echo OFF; fi)
+               -DWITH_DPDK=$(usex dpdk)
+               -DWITH_FUSE=$(usex fuse)
+               -DWITH_LTTNG=$(usex lttng)
+               -DWITH_GSSAPI=$(usex kerberos)
+               -DWITH_GRAFANA=$(usex grafana)
+               -DWITH_MGR=$(usex mgr)
+               -DWITH_MGR_DASHBOARD_FRONTEND=NO
+               -DWITH_NUMA=$(usex numa)
+               -DWITH_OPENLDAP=$(usex ldap)
+               -DMGR_PYTHON_VERSION=$(if python_is_python3; then echo 3; else echo 2; fi)
+               -DWITH_PYTHON3=$(if python_is_python3; then echo "ON"; else echo "OFF"; fi)
+               -DWITH_PYTHON2=$(if python_is_python3; then echo "OFF"; else echo "ON"; fi)
+               -DWITH_RADOSGW=$(usex radosgw)
+               -DWITH_RADOSGW_AMQP_ENDPOINT=$(usex rabbitmq)
+               -DWITH_SSL=$(usex ssl)
+               -DWITH_SYSTEMD=$(usex systemd)
+               -DWITH_TESTS=$(usex test)
+               -DWITH_XFS=$(usex xfs)
+               -DWITH_ZFS=$(usex zfs)
+               -DENABLE_SHARED=$(usex static-libs '' 'ON' 'OFF')
+               -DALLOCATOR=$(usex tcmalloc 'tcmalloc' "$(usex jemalloc 'jemalloc' 'libc')")
+               -DWITH_SYSTEM_BOOST=$(usex system-boost)
+               -DBOOST_J=$(makeopts_jobs)
+               -DWITH_RDMA=no
+               -DWITH_TBB=no
+               -DSYSTEMD_UNITDIR=$(systemd_get_systemunitdir)
+               -DEPYTHON_VERSION="${EPYTHON#python}"
+               -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PN}-${PVR}"
+               -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+               #-Wno-dev
+       )
+       if use amd64 || use x86; then
+               for flag in ${CPU_FLAGS_X86[@]}; do
+                       mycmakeargs+=("$(usex cpu_flags_x86_${flag} "-DHAVE_INTEL_${flag^^}=1")")
+               done
+       fi
+
+       rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
+               || die "failed to remove cmake cache"
+
+       cmake-utils_src_configure
+
+       # bug #630232
+       sed -i "s:\"${T//:\\:}/${EPYTHON}/bin/python\":\"${PYTHON}\":" \
+               "${BUILD_DIR:-${S}}"/include/acconfig.h \
+               || die "sed failed"
+}
+
+src_configure() {
+       ceph_src_configure
+}
+
+python_compile() {
+       local CMAKE_USE_DIR="${S}"
+       ceph_src_configure
+
+       pushd "${BUILD_DIR}/src/pybind" >/dev/null || die
+       emake VERBOSE=1 clean
+       emake VERBOSE=1 all
+
+       # python modules are only compiled with "make install" so we need to do this to
+       # prevent doing a bunch of compilation in src_install
+       DESTDIR="${T}" emake VERBOSE=1 install
+       popd >/dev/null || die
+}
+
+src_compile() {
+       cmake-utils_src_make VERBOSE=1 all
+
+       # we have to do this here to prevent from building everything multiple times
+       python_copy_sources
+       python_foreach_impl python_compile
+}
+
+src_test() {
+       make check || die "make check failed"
+}
+
+python_install() {
+       local CMAKE_USE_DIR="${S}"
+       pushd "${BUILD_DIR}/src/pybind" >/dev/null || die
+       DESTDIR="${ED}" emake VERBOSE=1 install
+       popd >/dev/null || die
+}
+
+src_install() {
+       cmake-utils_src_install
+       python_foreach_impl python_install
+
+       find "${ED}" -name '*.la' -type f -delete || die
+
+       exeinto /usr/$(get_libdir)/ceph
+       newexe "${BUILD_DIR}/bin/init-ceph" init-ceph
+
+       insinto /etc/logrotate.d/
+       newins "${FILESDIR}"/ceph.logrotate-r2 ${PN}
+
+       keepdir /var/lib/${PN}{,/tmp} /var/log/${PN}/stat
+
+       fowners -R ceph:ceph /var/lib/ceph /var/log/ceph
+
+       newinitd "${FILESDIR}/rbdmap.initd" rbdmap
+       newinitd "${FILESDIR}/${PN}.initd-r12" ${PN}
+       newconfd "${FILESDIR}/${PN}.confd-r5" ${PN}
+
+       insinto /etc/sysctl.d
+       newins "${FILESDIR}"/sysctld 90-${PN}.conf
+
+       use tcmalloc && newenvd "${FILESDIR}"/envd-tcmalloc 99${PN}-tcmalloc
+
+       # units aren't installed by the build system unless systemd is enabled
+       # so no point installing these with the USE flag disabled
+       if use systemd; then
+               systemd_install_serviced "${FILESDIR}/ceph-mds_at.service.conf" \
+                       "ceph-mds@.service"
+
+               systemd_install_serviced "${FILESDIR}/ceph-osd_at.service.conf" \
+                       "ceph-osd@.service"
+       fi
+
+       udev_dorules udev/*.rules
+
+       readme.gentoo_create_doc
+
+       python_setup 'python3*'
+
+       # bug #630232
+       sed -i -r "s:${T//:/\\:}/${EPYTHON}:/usr:" "${ED}"/usr/bin/ceph{,-crash} \
+               || die "sed failed"
+
+       python_fix_shebang "${ED}"/usr/{,s}bin/
+
+       # python_fix_shebang apparently is not idempotent
+       sed -i -r  's:(/usr/lib/python-exec/python[0-9]\.[0-9]/python)[0-9]\.[0-9]:\1:' \
+               "${ED}"/usr/sbin/{mount.*,ceph-volume{,-systemd}} || die "sed failed"
+
+       local -a rados_classes=( "${ED}/usr/$(get_libdir)/rados-classes"/* )
+       dostrip -x "${rados_classes[@]#${ED}}"
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}
diff --git a/sys-cluster/ceph/files/ceph-14.2.3-dpdk-compile-fix-1.patch b/sys-cluster/ceph/files/ceph-14.2.3-dpdk-compile-fix-1.patch
new file mode 100644 (file)
index 0000000..ef06758
--- /dev/null
@@ -0,0 +1,111 @@
+diff --git a/src/msg/async/dpdk/DPDKStack.cc b/src/msg/async/dpdk/DPDKStack.cc
+index 3101ae57ac..1db97c289a 100644
+--- a/src/msg/async/dpdk/DPDKStack.cc
++++ b/src/msg/async/dpdk/DPDKStack.cc
+@@ -203,7 +203,9 @@ DPDKWorker::Impl::~Impl()
+   _dev->unset_local_queue(id);
+ }
+
+-int DPDKWorker::listen(entity_addr_t &sa, const SocketOptions &opt,
++int DPDKWorker::listen(entity_addr_t &sa,
++                     unsigned addr_slot,
++                     const SocketOptions &opt,
+                        ServerSocket *sock)
+ {
+   ceph_assert(sa.get_family() == AF_INET);
+diff --git a/src/msg/async/dpdk/DPDKStack.h b/src/msg/async/dpdk/DPDKStack.h
+index a44ae38367..622ff8a3c6 100644
+--- a/src/msg/async/dpdk/DPDKStack.h
++++ b/src/msg/async/dpdk/DPDKStack.h
+@@ -37,7 +37,7 @@ class DPDKServerSocketImpl : public ServerSocketImpl {
+   typename Protocol::listener _listener;
+  public:
+   DPDKServerSocketImpl(Protocol& proto, uint16_t port, const SocketOptions &opt,
+-                     int type);
++                     int type, unsigned addr_slot);
+   int listen() {
+     return _listener.listen();
+   }
+@@ -184,8 +184,9 @@ class NativeConnectedSocketImpl : public ConnectedSocketImpl {
+
+ template <typename Protocol>
+ DPDKServerSocketImpl<Protocol>::DPDKServerSocketImpl(
+-  Protocol& proto, uint16_t port, const SocketOptions &opt, int type)
+-  : ServerSocketImpl(type), _listener(proto.listen(port)) {}
++  Protocol& proto, uint16_t port, const SocketOptions &opt,
++  int type, unsigned addr_slot)
++  : ServerSocketImpl(type, addr_slot), _listener(proto.listen(port)) {}
+
+ template <typename Protocol>
+ int DPDKServerSocketImpl<Protocol>::accept(ConnectedSocket *s, const SocketOptions &options, entity_addr_t *out, Worker *w) {
+@@ -229,7 +230,8 @@ class DPDKWorker : public Worker {
+
+  public:
+   explicit DPDKWorker(CephContext *c, unsigned i): Worker(c, i) {}
+-  virtual int listen(entity_addr_t &addr, const SocketOptions &opts, ServerSocket *) override;
++  virtual int listen(entity_addr_t &addr, unsigned addr_slot,
++                   const SocketOptions &opts, ServerSocket *) override;
+   virtual int connect(const entity_addr_t &addr, const SocketOptions &opts, ConnectedSocket *socket) override;
+   void arp_learn(ethernet_address l2, ipv4_address l3) {
+     _impl->_inet.learn(l2, l3);
+diff --git a/src/msg/async/dpdk/TCP.cc b/src/msg/async/dpdk/TCP.cc
+index c6397709b1..26f29e10f7 100644
+--- a/src/msg/async/dpdk/TCP.cc
++++ b/src/msg/async/dpdk/TCP.cc
+@@ -153,9 +153,10 @@ bool ipv4_tcp::forward(forward_hash& out_hash_data, Packet& p, size_t off)
+ }
+
+ int tcpv4_listen(tcp<ipv4_traits>& tcpv4, uint16_t port, const SocketOptions &opts,
+-                 int type, ServerSocket *sock)
++                 int type, unsigned addr_slot, ServerSocket *sock)
+ {
+-  auto p = new DPDKServerSocketImpl<tcp<ipv4_traits>>(tcpv4, port, opts, type);
++  auto p = new DPDKServerSocketImpl<tcp<ipv4_traits>>(tcpv4, port, opts,
++                                                    type, addr_slot);
+   int r = p->listen();
+   if (r < 0) {
+     delete p;
+diff --git a/src/msg/async/dpdk/DPDK.h b/src/msg/async/dpdk/DPDK.h
+index fa12af6b27..6bb52973e0 100644
+--- a/src/msg/async/dpdk/DPDK.h
++++ b/src/msg/async/dpdk/DPDK.h
+@@ -833,7 +833,7 @@ class DPDKDevice {
+   subscription<Packet> receive(unsigned cpuid, std::function<int (Packet)> next_packet) {
+     auto sub = _queues[cpuid]->_rx_stream.listen(std::move(next_packet));
+     _queues[cpuid]->rx_start();
+-    return std::move(sub);
++    return sub;
+   }
+   ethernet_address hw_address() {
+     struct ether_addr mac;
+@@ -849,7 +849,7 @@ class DPDKDevice {
+   std::unique_ptr<DPDKQueuePair> init_local_queue(CephContext *c, EventCenter *center, string hugepages, uint16_t qid) {
+     std::unique_ptr<DPDKQueuePair> qp;
+     qp = std::unique_ptr<DPDKQueuePair>(new DPDKQueuePair(c, center, this, qid));
+-    return std::move(qp);
++    return qp;
+   }
+   unsigned hash2qid(uint32_t hash) {
+     // return hash % hw_queues_count();
+diff --git a/src/msg/async/dpdk/Packet.h b/src/msg/async/dpdk/Packet.h
+index db9cd2a764..f929da3178 100644
+--- a/src/msg/async/dpdk/Packet.h
++++ b/src/msg/async/dpdk/Packet.h
+@@ -125,7 +125,7 @@ class Packet {
+       n->rss_hash.construct(old->rss_hash);
+       std::copy(old->frags, old->frags + old->_nr_frags, n->frags);
+       old->copy_internal_fragment_to(n.get());
+-      return std::move(n);
++      return n;
+     }
+
+     static std::unique_ptr<impl> copy(impl* old) {
+@@ -134,7 +134,7 @@ class Packet {
+
+     static std::unique_ptr<impl> allocate_if_needed(std::unique_ptr<impl> old, size_t extra_frags) {
+       if (old->_allocated_frags >= old->_nr_frags + extra_frags) {
+-        return std::move(old);
++        return old;
+       }
+       return copy(old.get(), std::max<size_t>(old->_nr_frags + extra_frags, 2 * old->_nr_frags));
+     }