sys-fs/multipath-tools: fix building against GCC 10
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 3 May 2020 19:18:28 +0000 (21:18 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 3 May 2020 19:18:38 +0000 (21:18 +0200)
Closes: https://bugs.gentoo.org/706670
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch [new file with mode: 0644]
sys-fs/multipath-tools/multipath-tools-0.8.3-r2.ebuild

diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch
new file mode 100644 (file)
index 0000000..18ed8d6
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/libmultipath/structs.h
++++ b/libmultipath/structs.h
+@@ -106,7 +106,7 @@ enum yes_no_undef_states {
+  * _FIND_MULTIPATHS_F must have the same value as YNU_YES.
+  * Generate a compile time error if that isn't the case.
+  */
+-char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
++extern char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
+ #define find_multipaths_on(conf) \
+       (!!((conf)->find_multipaths & _FIND_MULTIPATHS_F))
index feb9ba35c8457f2d30834c83749b6a180632eaeb..718daba1fda5fe0ab3259abcf8e9dc043d176dca 100644 (file)
@@ -37,6 +37,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-0.7.5-respect-flags.patch
        "${FILESDIR}"/${PN}-0.8.3-no-gziped-docs.patch
        "${FILESDIR}"/${PN}-0.8.3-json-c-0.14.patch
+       "${FILESDIR}"/${PN}-0.8.3-fix-gcc-10-compatibility.patch
 )
 
 get_systemd_pv() {