dev-python/hpack: Disable Hypothesis health checks
authorMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 20:40:37 +0000 (21:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 21:25:07 +0000 (22:25 +0100)
Hypothesis health checks are of no use to Gentoo users, and needlessly
cause tests to fail, possibly due to bugs in Hypothesis itself.  Disable
them.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hpack/files/hpack-3.0.0-hypothesis-healthcheck.patch [new file with mode: 0644]
dev-python/hpack/hpack-3.0.0.ebuild

diff --git a/dev-python/hpack/files/hpack-3.0.0-hypothesis-healthcheck.patch b/dev-python/hpack/files/hpack-3.0.0-hypothesis-healthcheck.patch
new file mode 100644 (file)
index 0000000..aaabac3
--- /dev/null
@@ -0,0 +1,21 @@
+diff --git a/test/conftest.py b/test/conftest.py
+index f5801da..c5e3c66 100644
+--- a/test/conftest.py
++++ b/test/conftest.py
+@@ -4,11 +4,16 @@ import os
+ import json
+ import sys
++from hypothesis import settings, HealthCheck
+ from hypothesis.strategies import text
+ if sys.version_info[0] == 2:
+     from codecs import open
++settings.register_profile("gentoo",
++        suppress_health_check=(HealthCheck.too_slow,))
++settings.load_profile("gentoo")
++
+ # We need to grab one text example from hypothesis to prime its cache.
+ text().example()
index 65570c88f59dc5e3aff83265d413aaa5837b1698..d6235dee735db1237f9a686f37ed913085d14cb8 100644 (file)
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
        )
 "
 
+PATCHES=(
+       "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
+)
+
 python_prepare_all() {
        # Remove a test that is not part of the mainstream tests
        # Also, it's data directory is not included in the release