app-emulation/diskimage-builder: 2.34.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 14 Mar 2020 16:38:02 +0000 (11:38 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 14 Mar 2020 16:38:18 +0000 (11:38 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.34.1.ebuild [new file with mode: 0644]

index 451b4863396983cf60d3c41fd27b1dda46f2dd91..438be755dc4726e022a0bc8b98290b01b8366ce8 100644 (file)
@@ -1,2 +1,3 @@
 DIST diskimage-builder-2.33.0.tar.gz 434041 BLAKE2B 16d14c68e7a54b785426516ecced4adb53b4e84f36d36846732ef7c4823644375373249ceacd1371e39262ebc9050f2f86184718dc3fb17b44eaa20f561410c0 SHA512 125bdcc0a2d4249918485115c49482746e4f86cb7883d3689afd4288a0d18ca97bcb669b811034ccb159879520172ca37bd9f9d7ba4ea509f788be0f3cf2259b
 DIST diskimage-builder-2.34.0.tar.gz 436267 BLAKE2B b234385fedb48ec32c7fb8b684bd5531e04e342b237cc2090bd69742774a58868a1021767fb281a06cff1507d7d0c109ecb26caea61d0075ddf1a0fff9b1b48b SHA512 ddad45d57fc59c64a07276492354a7ea6d6aea76e300f1fce202208159a285c51dfc851f6630287b19c9f5685315cdcab1125e37cea90a92c361ea38e82a5a33
+DIST diskimage-builder-2.34.1.tar.gz 429161 BLAKE2B e408a3018b0628f82bacaeadc6d55527dac108ae6a0516761b43b684f0b3c98aaeba7303474b0abed38b526092c48c984dcd1d6af755a0a17c039899988c5261 SHA512 1f529a217ba249fc88e2ffb3647819aac8cd5ace9eaa2df0ca731a7aeff96d5203c68252f0dbc5918d01884a4ed10ed8badb50edb0b732835de9710929396569
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.34.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.34.1.ebuild
new file mode 100644 (file)
index 0000000..092a05d
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       app-emulation/qemu
+       sys-block/parted
+       sys-fs/multipath-tools
+       sys-fs/dosfstools
+       sys-apps/gptfdisk
+       !dev-python/dib-utils[${PYTHON_USEDEP}]"