net-misc/eventd: disable wayland support due to missing dep
authorJoonas Niilola <juippis@gentoo.org>
Thu, 28 May 2020 11:57:57 +0000 (14:57 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 28 May 2020 11:58:11 +0000 (14:58 +0300)
Closes: https://bugs.gentoo.org/702820
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/eventd/eventd-0.27.0-r1.ebuild

index 5805963615d59227e84baae4c9c0899913081aec..e533b5124a7eb813f8b44662cb27935a8fb3d59d 100644 (file)
@@ -13,8 +13,7 @@ LICENSE="GPL-3+ LGPL-3+ ISC MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
-       pulseaudio purple speech systemd test upnp wayland webhook websocket
-       +X zeroconf"
+       pulseaudio purple speech systemd test upnp webhook websocket +X zeroconf"
 
 RESTRICT="!test? ( test )"
 REQUIRED_USE="
@@ -51,7 +50,6 @@ COMMON_DEPEND="
        speech? ( app-accessibility/speech-dispatcher )
        systemd? ( sys-apps/systemd:= )
        upnp? ( >=net-libs/gssdp-1.2:0= )
-       wayland? ( dev-libs/wayland )
        webhook? ( net-libs/libsoup:2.4 )
        websocket? ( net-libs/libsoup:2.4 )
        zeroconf? ( net-dns/avahi[dbus] )
@@ -78,17 +76,18 @@ pkg_setup() {
 }
 
 src_configure() {
+       # wayland disabled due to missing dep in ::gentoo, wayland-wall
        local emesonargs=(
                -Dsystemduserunitdir="$(systemd_get_userunitdir)"
                -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
                -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+               -Dnd-wayland=false
                $(meson_feature websocket)
                $(meson_feature zeroconf dns-sd)
                $(meson_feature upnp ssdp)
                $(meson_use ipv6)
                $(meson_use systemd)
                $(meson_use notification notification-daemon)
-               $(meson_use wayland nd-wayland)
                $(meson_use X nd-xcb)
                $(meson_use fbcon nd-fbdev)
                $(meson_use purple im)