dev-lisp/clisp: Rolling back last clisp commit
authorChema Alonso Josa <nimiux@gentoo.org>
Mon, 5 Mar 2018 17:21:19 +0000 (18:21 +0100)
committerChema Alonso Josa <nimiux@gentoo.org>
Mon, 5 Mar 2018 17:21:41 +0000 (18:21 +0100)
dev-lisp/clisp/Manifest
dev-lisp/clisp/clisp-2.48-r1.ebuild [new file with mode: 0644]
dev-lisp/clisp/clisp-2.48-r2.ebuild [new file with mode: 0644]
dev-lisp/clisp/metadata.xml

index 0210e80c05b2600efda443eced81a1a11605b518..7c0c8d6ab64b9c4cb902d53e053db9aaa797904a 100644 (file)
@@ -1,3 +1,4 @@
+DIST clisp-2.48.tar.bz2 7885098 BLAKE2B 42ebfe4721015f522184bce710bf95d79aa7f2a239410af249a8e85d80f140344ec80daaa34f7cdbfd2ae86407984657163ce3f6e4201eb132f7c71e21523cba SHA512 3288b6a2973c924006b14bbed1e8e3e688276a187ac2a6c7851dc7ae699e7832d30e5e7eecdabc76c08c7e8e8ce1b562eb97a44570d3035e558ea2310de2b719
 DIST clisp-2.49.60.tar.bz2 8745713 BLAKE2B 5dffd594c6d00c2057a98e3f93c888cd5cdc60009cd8fc987e39ff5182e71e575e148839d9c973fbfd0842b82ddf1b5918e86d128d9c79f6d0d4b6afcdc5853f SHA512 656cd59a23ba9be5304a6e0d64d79ac518072c431820b8cf95759fa8f3a66e2efe4d07939315b93e5e06b6e5348d8b32739b129a9e8ac0dc362dd5d1f1eb8aa8
 DIST clisp-2.49.90.tar.bz2 8921458 BLAKE2B 3be7cfe41038f42d8844d500877fa5c20e5c21dc0e162aa0018b297e4dfcd5374ef608793c9d809852e1f9885a155bb5b25fef8efe66016dd0ee400007386b70 SHA512 1fa7205e38883dcc863160b5418ddaaa2c45ee2d2f936de4067d1ea4a1e5043bf1235361bbbfc366afd6d8f1144497ccdccf1767ecf327f7a672b18742ceb651
 DIST clisp-2.49.tar.bz2 8091011 BLAKE2B e034c581b8100837b34d0adf1ef45bd667272d062945875175958178b4ef5b11e899dfb76505eb8cb51fca6101c11a9f21fb2cc9a78a3c0f82b06166211434f7 SHA512 eef66fc85199a2c283b616db61bf67ff103eeb0f19fa907da48994dc790b6f5f8d0c74fb3bd723c6b827c0ff3cfd89fa6ba67934fc669ed5d5249044b5140d81
diff --git a/dev-lisp/clisp/clisp-2.48-r1.ebuild b/dev-lisp/clisp/clisp-2.48-r1.ebuild
new file mode 100644 (file)
index 0000000..a91495a
--- /dev/null
@@ -0,0 +1,165 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ia64 ppc -sparc x86"
+IUSE="berkdb hyperspec X new-clx dbus fastcgi gdbm gtk pari +pcre postgres +readline svm -threads +unicode +zlib"
+
+RDEPEND="virtual/libiconv
+                >=dev-libs/libsigsegv-2.4
+                >=dev-libs/ffcall-1.10
+                dbus? ( sys-apps/dbus )
+                fastcgi? ( dev-libs/fcgi )
+                gdbm? ( sys-libs/gdbm )
+                gtk? ( >=x11-libs/gtk+-2.10:2 >=gnome-base/libglade-2.6:2.0 )
+                pari? ( >=sci-mathematics/pari-2.3.0 )
+                postgres? ( >=dev-db/postgresql-8.0 )
+                readline? ( >=sys-libs/readline-5.0 )
+                pcre? ( dev-libs/libpcre )
+                svm? ( sci-libs/libsvm )
+                zlib? ( sys-libs/zlib )
+                X? ( new-clx? ( x11-libs/libXpm ) )
+                hyperspec? ( dev-lisp/hyperspec )
+                berkdb? ( sys-libs/db:4.5 )"
+
+DEPEND="${RDEPEND}
+       X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PDEPEND="dev-lisp/gentoo-init"
+
+enable_modules() {
+       [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+       for m in "$@" ; do
+               einfo "enabling module $m"
+               myconf+=" --with-module=${m}"
+       done
+}
+
+BUILDDIR="builddir"
+
+# modules not enabled:
+#  * berkdb: must figure out a way to make the configure script pick up the
+#            currect version of the library and headers
+#  * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
+#  * matlab, netica: not in portage
+#  * oracle: can't install oracle-instantclient
+
+src_prepare() {
+       # More than -O1 breaks alpha/ia64
+       if use alpha || use ia64; then
+               sed -i -e 's/-O2//g' src/makemake.in || die
+       fi
+}
+
+src_configure() {
+       # We need this to build on alpha/ia64
+       if use alpha || use ia64; then
+               replace-flags -O? -O1
+               append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
+       fi
+
+       # QA issue with lisp.run
+       append-flags -Wa,--noexecstack
+
+       # built-in features
+       local myconf="--with-ffcall --without-dynamic-modules"
+#    There's a problem with jit_allocai function
+#    if use jit; then
+#        myconf+=" --with-jitc=lightning"
+#    fi
+       if use threads; then
+               myconf+=" --with-threads=POSIX_THREADS"
+       fi
+
+       # default modules
+       enable_modules wildcard rawsock
+       # optional modules
+       use elibc_glibc && enable_modules bindings/glibc
+       if use X; then
+               if use new-clx; then
+                       enable_modules clx/new-clx
+               else
+                       enable_modules clx/mit-clx
+               fi
+       fi
+       if use postgres; then
+               enable_modules postgresql
+               append-flags -I$(pg_config --includedir)
+       fi
+       if use berkdb; then
+               enable_modules berkeley-db
+               append-flags -I/usr/include/db4.5
+       fi
+       use dbus && enable_modules dbus
+       use fastcgi && enable_modules fastcgi
+       use gdbm && enable_modules gdbm
+       use gtk && enable_modules gtk2
+       use pari && enable_modules pari
+       use pcre && enable_modules pcre
+       use svm && enable_modules libsvm
+       use zlib && enable_modules zlib
+
+       if use hyperspec; then
+               CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
+       else
+               CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
+       fi
+
+       # configure chokes on --sysconfdir option
+       local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+               $(use_with readline) $(use_with unicode) \
+               ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
+       einfo "${configure}"
+       ${configure} || die "./configure failed"
+
+       sed -i 's,"vi","nano",g' "${BUILDDIR}"/config.lisp || die
+
+       IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
+       sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" \
+               "${BUILDDIR}"/config.lisp || die
+}
+
+src_compile() {
+       export VARTEXFONTS="${T}"/fonts
+       cd "${BUILDDIR}"
+       # parallel build fails
+       emake -j1 || die "emake failed"
+}
+
+src_install() {
+       pushd "${BUILDDIR}"
+       make DESTDIR="${D}" prefix=/usr install-bin || die
+       doman clisp.1 || die
+       dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE || die
+       fperms a+x /usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link || die
+       # stripping them removes common symbols (defined but uninitialised variables)
+       # which are then needed to build modules...
+       export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
+       popd
+       dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png || die
+       dodoc doc/{CLOS-guide,LISP-tutorial}.txt || die
+}
+
+pkg_postinst() {
+       if use threads || use jit; then
+               while read line; do elog ${line}; done <<EOF
+
+Upstream considers threads to be of Alpha quality, therefore
+it is likely that you will encounter bugs in using them. If you do,
+please report bugs upstream:
+
+Mailing list: https://lists.sourceforge.net/lists/listinfo/clisp-devel
+Bug tracker:  https://sourceforge.net/tracker/?atid=101355&group_id=1355
+
+EOF
+       fi
+}
diff --git a/dev-lisp/clisp/clisp-2.48-r2.ebuild b/dev-lisp/clisp/clisp-2.48-r2.ebuild
new file mode 100644 (file)
index 0000000..95be00d
--- /dev/null
@@ -0,0 +1,164 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc -sparc x86"
+IUSE="berkdb hyperspec X new-clx dbus fastcgi gdbm gtk pari +pcre postgres +readline svm -threads +unicode +zlib"
+
+RDEPEND="virtual/libiconv
+                >=dev-libs/libsigsegv-2.4
+                >=dev-libs/ffcall-1.10
+                dbus? ( sys-apps/dbus )
+                fastcgi? ( dev-libs/fcgi )
+                gdbm? ( sys-libs/gdbm )
+                gtk? ( >=x11-libs/gtk+-2.10:2 >=gnome-base/libglade-2.6:2.0 )
+                pari? ( >=sci-mathematics/pari-2.3.0 )
+                postgres? ( >=dev-db/postgresql-8.0 )
+                readline? ( >=sys-libs/readline-5.0 )
+                pcre? ( dev-libs/libpcre )
+                svm? ( sci-libs/libsvm )
+                zlib? ( sys-libs/zlib )
+                X? ( new-clx? ( x11-libs/libXpm ) )
+                hyperspec? ( dev-lisp/hyperspec )
+                berkdb? ( sys-libs/db:4.7 )"
+
+DEPEND="${RDEPEND}
+       X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PDEPEND="dev-lisp/gentoo-init"
+
+enable_modules() {
+       [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+       for m in "$@" ; do
+               einfo "enabling module $m"
+               myconf+=" --with-module=${m}"
+       done
+}
+
+BUILDDIR="builddir"
+
+# modules not enabled:
+#  * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
+#  * matlab, netica: not in portage
+#  * oracle: can't install oracle-instantclient
+
+src_prepare() {
+       # More than -O1 breaks alpha/ia64
+       if use alpha || use ia64; then
+               sed -i -e 's/-O2//g' src/makemake.in || die
+       fi
+       epatch "${FILESDIR}/${P}-bits_ipctypes_to_sys_ipc.patch"
+}
+
+src_configure() {
+       # We need this to build on alpha/ia64
+       if use alpha || use ia64; then
+               replace-flags -O? -O1
+               append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
+       fi
+
+       # QA issue with lisp.run
+       append-flags -Wa,--noexecstack
+
+       # built-in features
+       local myconf="--with-ffcall --without-dynamic-modules"
+#    There's a problem with jit_allocai function
+#    if use jit; then
+#        myconf+=" --with-jitc=lightning"
+#    fi
+       if use threads; then
+               myconf+=" --with-threads=POSIX_THREADS"
+       fi
+
+       # default modules
+       enable_modules wildcard rawsock
+       # optional modules
+       use elibc_glibc && enable_modules bindings/glibc
+       if use X; then
+               if use new-clx; then
+                       enable_modules clx/new-clx
+               else
+                       enable_modules clx/mit-clx
+               fi
+       fi
+       if use postgres; then
+               enable_modules postgresql
+               append-flags -I$(pg_config --includedir)
+       fi
+       if use berkdb; then
+               enable_modules berkeley-db
+               append-flags -I/usr/include/db4.7
+       fi
+       use dbus && enable_modules dbus
+       use fastcgi && enable_modules fastcgi
+       use gdbm && enable_modules gdbm
+       use gtk && enable_modules gtk2
+       use pari && enable_modules pari
+       use pcre && enable_modules pcre
+       use svm && enable_modules libsvm
+       use zlib && enable_modules zlib
+
+       if use hyperspec; then
+               CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
+       else
+               CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
+       fi
+
+       # configure chokes on --sysconfdir option
+       local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+               $(use_with readline) $(use_with unicode) \
+               ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
+       einfo "${configure}"
+       ${configure} || die "./configure failed"
+
+       sed -i 's,"vi","nano",g' "${BUILDDIR}"/config.lisp || die
+
+       IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
+       sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" \
+               "${BUILDDIR}"/config.lisp || die
+}
+
+src_compile() {
+       export VARTEXFONTS="${T}"/fonts
+       cd "${BUILDDIR}"
+       # parallel build fails
+       emake -j1 || die "emake failed"
+}
+
+src_install() {
+       pushd "${BUILDDIR}"
+       make DESTDIR="${D}" prefix=/usr install-bin || die
+       doman clisp.1 || die
+       dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE || die
+       fperms a+x /usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link || die
+       # stripping them removes common symbols (defined but uninitialised variables)
+       # which are then needed to build modules...
+       export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
+       popd
+       dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png || die
+       dodoc doc/{CLOS-guide,LISP-tutorial}.txt || die
+}
+
+pkg_postinst() {
+       if use threads || use jit; then
+               while read line; do elog ${line}; done <<EOF
+
+Upstream considers threads to be of Alpha quality, therefore
+it is likely that you will encounter bugs in using them. If you do,
+please report bugs upstream:
+
+Mailing list: https://lists.sourceforge.net/lists/listinfo/clisp-devel
+Bug tracker:  https://sourceforge.net/tracker/?atid=101355&group_id=1355
+
+EOF
+       fi
+}
index d7c63a79485d8516dc36d082e338834e220cd2db..a78f41563fce83ddf78f10919a4ed51bcfc8a2c5 100644 (file)
@@ -20,6 +20,8 @@ changed at run time.
 </longdescription>
        <use>
                <flag name="hyperspec">Use local hyperspec instead of online version</flag>
+               <flag name="new-clx">Build CLISP with support for the NEW-CLX module which is a
+-C binding to the Xorg libraries</flag>
                <flag name="pari">Build CLISP with support for the PARI Computer Algebra System</flag>
                <flag name="svm">Build CLISP with support for the Support Vector Machine module</flag>
        </use>