dev-libs/libtasn1: cleanup
authorAlon Bar-Lev <alonbl@gentoo.org>
Sun, 22 Apr 2018 21:14:27 +0000 (00:14 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sun, 22 Apr 2018 21:15:19 +0000 (00:15 +0300)
Bug: https://bugs.gentoo.org/show_bug.cgi?id=647012
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-libs/libtasn1/Manifest
dev-libs/libtasn1/files/libtasn1-4.12-CVE-2017-10790.patch [deleted file]
dev-libs/libtasn1/libtasn1-4.12-r1.ebuild [deleted file]

index 233c11fca37a9bb91b2dbfe1db50cb44b55e3217..527b14e9c6f536a3be6cfc66d43ee49be673aacc 100644 (file)
@@ -1,2 +1 @@
-DIST libtasn1-4.12.tar.gz 1888450 BLAKE2B ccd3d5c7bbc9d00fd5be125a60b1705833bee4dff8bd0147cc6a7ed67ed679210984dedcf5d76f701ab53b8d7c127580ddb3162876aea9e1142f518271d12252 SHA512 6c551670949881193e39122f72948e4999ff1ba377f9ee5963d0a4ad1b84256e4fe42e9f6d6a2aa9f7d4ef7acc0e5174fb5cc3df5298524cdeda92f4b8c104f7
 DIST libtasn1-4.13.tar.gz 1891703 BLAKE2B 5a8bfefe1a3701505c8a1a4920412a6dd15fe771fb848fbd00f0a332388795dc6108a0fa5a282b4212abe0b0642f205bda53c2c39a4a2d65fa71e082fc76a6d2 SHA512 bf5b60a296795e0a8a4a658c0106492393aa7ce698e785256b3427c17215c2a5b6178a61a2043c93ea4334f754eabece20221ac8fef0fd5644086a3891d98a9f
diff --git a/dev-libs/libtasn1/files/libtasn1-4.12-CVE-2017-10790.patch b/dev-libs/libtasn1/files/libtasn1-4.12-CVE-2017-10790.patch
deleted file mode 100644 (file)
index eb752c2..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-From d8d805e1f2e6799bb2dff4871a8598dc83088a39 Mon Sep 17 00:00:00 2001
-From: Nikos Mavrogiannopoulos <nmav@redhat.com>
-Date: Thu, 22 Jun 2017 16:31:37 +0200
-Subject: [PATCH] _asn1_check_identifier: safer access to values read
-
-Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
----
- lib/parser_aux.c | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/lib/parser_aux.c b/lib/parser_aux.c
-index 976ab38..786ea64 100644
---- a/lib/parser_aux.c
-+++ b/lib/parser_aux.c
-@@ -955,7 +955,7 @@ _asn1_check_identifier (asn1_node node)
-         if (p2 == NULL)
-           {
-             if (p->value)
--              _asn1_strcpy (_asn1_identifierMissing, p->value);
-+              _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p->value);
-             else
-               _asn1_strcpy (_asn1_identifierMissing, "(null)");
-             return ASN1_IDENTIFIER_NOT_FOUND;
-@@ -968,9 +968,15 @@ _asn1_check_identifier (asn1_node node)
-         if (p2 && (type_field (p2->type) == ASN1_ETYPE_DEFAULT))
-           {
-             _asn1_str_cpy (name2, sizeof (name2), node->name);
--            _asn1_str_cat (name2, sizeof (name2), ".");
--            _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
--            _asn1_strcpy (_asn1_identifierMissing, p2->value);
-+            if (p2->value)
-+              {
-+                _asn1_str_cat (name2, sizeof (name2), ".");
-+                _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
-+                _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
-+              }
-+            else
-+              _asn1_strcpy (_asn1_identifierMissing, "(null)");
-+
-             p2 = asn1_find_node (node, name2);
-             if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID) ||
-                 !(p2->type & CONST_ASSIGN))
-@@ -990,7 +996,8 @@ _asn1_check_identifier (asn1_node node)
-                 _asn1_str_cpy (name2, sizeof (name2), node->name);
-                 _asn1_str_cat (name2, sizeof (name2), ".");
-                 _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
--                _asn1_strcpy (_asn1_identifierMissing, p2->value);
-+                _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
-+
-                 p2 = asn1_find_node (node, name2);
-                 if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID)
-                     || !(p2->type & CONST_ASSIGN))
--- 
-1.9.1
-
diff --git a/dev-libs/libtasn1/libtasn1-4.12-r1.ebuild b/dev-libs/libtasn1/libtasn1-4.12-r1.ebuild
deleted file mode 100644 (file)
index b1be42b..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib-minimal libtool ltprune
-
-DESCRIPTION="ASN.1 library"
-HOMEPAGE="https://www.gnu.org/software/libtasn1/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-2.1"
-SLOT="0/6" # subslot = libtasn1 soname version
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs valgrind"
-
-DEPEND=">=dev-lang/perl-5.6
-       sys-apps/help2man
-       virtual/yacc"
-RDEPEND="
-       valgrind? ( dev-util/valgrind )
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-PATCHES=(
-       "${FILESDIR}/${P}-CVE-2017-10790.patch"
-)
-
-pkg_setup() {
-       if use doc; then
-               DOCS+=( doc/libtasn1.pdf )
-               HTML_DOCS=( doc/reference/html/. )
-       fi
-}
-
-src_prepare() {
-       default
-       elibtoolize  # for Solaris shared library
-}
-
-multilib_src_configure() {
-       ECONF_SOURCE="${S}" econf \
-               $(use_enable static-libs static) \
-               $(multilib_native_use_enable valgrind valgrind-tests)
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       prune_libtool_files
-}