dev-python/keystoneauth: 3.17.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 25 Feb 2020 17:50:39 +0000 (11:50 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 25 Feb 2020 17:52:16 +0000 (11:52 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/keystoneauth/Manifest
dev-python/keystoneauth/keystoneauth-3.17.2.ebuild [new file with mode: 0644]

index b0e466a16e1d6ff28b3a93cae0a515df9487625a..4b4dba85b0d095a72e37e703af91426ee45dde06 100644 (file)
@@ -1 +1,2 @@
 DIST keystoneauth1-3.17.1.tar.gz 253985 BLAKE2B 4df40a5cb993d6bec3972152d7557c03b9283621f58f4c6d29b680eafabaa0ee4ec60dc52851738f22c6f3182339e6bb0554e6a4ce9ace30473a902b74a57b52 SHA512 ca2f5a46450ed9a772bfbf882ab23ac4f251b2209ad038190fca41af0626616ae4f607ae03fb837b1e7bd87c2c239dfae64bc122ffc8db551451d95353743016
+DIST keystoneauth1-3.17.2.tar.gz 253877 BLAKE2B 9a8f10a5a535ee6ee02859f6a7da38777af250303d0be0feed266c677fea3f6bd465e3e14309c38f67dc5886c846a6aa9a9a7438f5e511f7a80782e29ce88b52 SHA512 6ead83db401d9bb31df87da5c9eff576f621d0b0964c9423de6cdd45777b9a2e3cef27fc20d91fc01b82c64b9b0ffcb83f270b4df7b740319809207ed0b2cb2a
diff --git a/dev-python/keystoneauth/keystoneauth-3.17.2.ebuild b/dev-python/keystoneauth/keystoneauth-3.17.2.ebuild
new file mode 100644 (file)
index 0000000..21ce2d5
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"