dev-python/python-virtkey: fix invalid dev-libs/glib[$PYTHON_USEDEP] dep
authorMart Raudsepp <leio@gentoo.org>
Mon, 20 Aug 2018 06:16:11 +0000 (09:16 +0300)
committerMart Raudsepp <leio@gentoo.org>
Mon, 20 Aug 2018 06:18:47 +0000 (09:18 +0300)
Use eapi7-ver instead of versionator while here

Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/python-virtkey/python-virtkey-0.60.0-r2.ebuild [moved from dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild with 68% similarity]

similarity index 68%
rename from dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild
rename to dev-python/python-virtkey/python-virtkey-0.60.0-r2.ebuild
index b1a384ee576f155b19eac1d2dda3f161dcee0350..b4cfca78c4788f94f164922685d735f0a1adbe0f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -6,11 +6,11 @@ EAPI=5
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_SINGLE_IMPL=1
 
-inherit distutils-r1 flag-o-matic versionator
+inherit distutils-r1 eapi7-ver flag-o-matic
 
 DESCRIPTION="Python module to simulate keypresses and get current keyboard layout"
 HOMEPAGE="https://launchpad.net/virtkey"
-SRC_URI="https://launchpad.net/python-virtkey/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+SRC_URI="https://launchpad.net/python-virtkey/$(ver_cut 1-2)/${PV}/+download/${P}.tar.gz"
 
 LICENSE="LGPL-2"
 SLOT="0"
@@ -18,7 +18,7 @@ KEYWORDS="amd64 x86"
 IUSE=""
 
 RDEPEND="
-       dev-libs/glib:2[${PYTHON_USEDEP}]
+       dev-libs/glib:2
        x11-libs/libX11
        x11-libs/libXtst
        x11-libs/gtk+:2"