dev-python/reproject: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:42:41 +0000 (19:42 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:42:41 +0000 (19:42 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/reproject/Manifest [deleted file]
dev-python/reproject/metadata.xml [deleted file]
dev-python/reproject/reproject-0.3.1.ebuild [deleted file]

diff --git a/dev-python/reproject/Manifest b/dev-python/reproject/Manifest
deleted file mode 100644 (file)
index 6f14736..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST reproject-0.3.1.tar.gz 653996 BLAKE2B 6dca886dab21922d76bc32fbfb068264f206459b364c23beab7eb10990cdf6dec7c998e3b0cdc70fa8d5dd83c3c38010c6a39bca26775a8dbd692fc15295ac90 SHA512 5739ee812862e6558c46ebd79b9b73214093df2b6d0c603d94586c0f8908a4b29004f07380ca143fb59bcc4d33c19b0a81a1185b1a2cc60ff7be943c0f1e243f
diff --git a/dev-python/reproject/metadata.xml b/dev-python/reproject/metadata.xml
deleted file mode 100644 (file)
index 7a7ae65..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-    This is a package to reproject astronomical images using various techniques
-    via a uniform interface. Reprojection means the re-gridding of images from
-    one world coordinate system to another (for example changing the pixel
-    resolution, orientation, coordinate system). Currently implemented are
-    reprojection of celestial images by interpolation, as well as by finding the
-    exact overlap between pixels on the celestial sphere. It can also reproject
-    to/from HEALPIX projections.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">reproject</remote-id>
-  </upstream>
-</pkgmetadata>
diff --git a/dev-python/reproject/reproject-0.3.1.ebuild b/dev-python/reproject/reproject-0.3.1.ebuild
deleted file mode 100644 (file)
index 9feca26..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Reproject astronomical images with Python"
-HOMEPAGE="http://reproject.readthedocs.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx -w
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/ )
-       distutils-r1_python_install_all
-}