dev-python/pyopencl: Drop unmaintained -9999
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 19:06:50 +0000 (20:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 19:16:51 +0000 (20:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyopencl/pyopencl-9999.ebuild [deleted file]

diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
deleted file mode 100644 (file)
index 8055a67..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 git-2
-
-EGIT_REPO_URI="https://git.tiker.net/trees/pyopencl.git"
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl
-       https://pypi.org/project/pyopencl/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
-       dev-python/decorator[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/mako[${PYTHON_USEDEP}]
-       >=dev-python/pytools-9999[${PYTHON_USEDEP}]
-       >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-src_configure()
-{
-       local myconf=()
-       if use opengl; then
-               myconf+=(--cl-enable-gl)
-       fi
-
-       "${PYTHON}" configure.py \
-               --boost-compiler=gcc \
-               --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
-               --no-use-shipped-boost \
-               "${myconf[@]}"
-}
-
-python_install_all() {
-       if use examples; then
-               local EXAMPLES=( examples/. )
-               einfo "Some of the examples provided by this package require dev-python/matplotlib."
-       fi
-       distutils-r1_python_install_all
-}