sys-libs/compiler-rt: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:51 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:53 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild

index 13a5397acde0a4af6a3804dfc4999671dc484b14..fe9fd52093ac3e5cae5a6005ce4ae78d164c4ac7 100644 (file)
@@ -14,8 +14,8 @@ inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
 DESCRIPTION="Compiler runtime library for clang (built-in part)"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
-       https://github.com/llvm-mirror/compiler-rt.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/compiler-rt
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="$(ver_cut 1-3)"
@@ -49,6 +49,11 @@ pkg_setup() {
        python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' compiler-rt
+}
+
 test_compiler() {
        $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
                <<<'int main() { return 0; }' &>/dev/null
index 88bfd8aa0ad293d3d68618fdfbfebb5f2acdc492..898c8d917487d5bf3a579eaed59ee3511b98130f 100644 (file)
@@ -14,9 +14,9 @@ inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
 DESCRIPTION="Compiler runtime library for clang (built-in part)"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
-       https://github.com/llvm-mirror/compiler-rt.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/compiler-rt
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="$(ver_cut 1-3)"
@@ -50,6 +50,11 @@ pkg_setup() {
        python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' compiler-rt
+}
+
 test_compiler() {
        $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
                <<<'int main() { return 0; }' &>/dev/null