media-gfx/yafaray: Switch to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Jan 2020 18:59:28 +0000 (19:59 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Jan 2020 18:59:28 +0000 (19:59 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/yafaray/yafaray-3.3.0-r2.ebuild

index c54d1fbb0c7e42106b79fe12d6d0eee13a65af25..dfaafd34cbbf83b8e2ac8d60dc7adc2f23d03cf9 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 PYTHON_COMPAT=( python3_{5,6,7} )
 
-inherit cmake-utils flag-o-matic python-single-r1
+inherit cmake flag-o-matic python-single-r1
 
 DESCRIPTION="A free open-source montecarlo raytracing engine"
 HOMEPAGE="http://www.yafaray.org"
@@ -41,7 +41,7 @@ pkg_setup() {
 
 src_prepare() {
        append-flags "-pthread"
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i -e "s/@YAFARAY_BLENDER_EXPORTER_VERSION@/v${PV}/" "${WORKDIR}/Blender-Exporter-${PV}/__init__.py" || die
 
@@ -72,11 +72,11 @@ src_configure() {
                -DWITH_Freetype="$(usex truetype)"
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        python_domodule "${BUILD_DIR}/src/bindings/yafaray_v3_interface.py"
        python_domodule "${BUILD_DIR}/src/bindings/_yafaray_v3_interface.so"