app-admin/ulogd: Restore ebuild and Manifest entry from previous clean up.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 28 Sep 2015 07:51:47 +0000 (07:51 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 28 Sep 2015 07:53:49 +0000 (07:53 +0000)
Package-Manager: portage-2.2.18
RepoMan-Options: --force
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-admin/ulogd/Manifest
app-admin/ulogd/ulogd-2.0.4-r1.ebuild [new file with mode: 0644]

index d969037d459d6e4352755909ea18ff7b7d38775d..8392508578e9f1e2414d1151d1e07b43474035f7 100644 (file)
@@ -1 +1,2 @@
+DIST ulogd-2.0.4.tar.bz2 452234 SHA256 56b30a13a8832e97178f39b7bb173a0b1dfe173dbb60d99a1a386c0962a2effd SHA512 08e88661fcfbcfd327b03b7a883dc239991f47d5a4e4561f3ada5f6acc8f2349f3bd38c1c67f28e42bbccf4cad63b2b7c3b732c23bf24b7c5f05320d27977773 WHIRLPOOL 94ee731cee8b95295d1c675bb3904be1a5b27a1e901d462f248116c865e79d52703b5330882110d7212bda1bb964fc0c97c3e704589071f47fab4475e1c91161
 DIST ulogd-2.0.5.tar.bz2 456258 SHA256 a221cb9f77347c0ca00d0937e27c1b90e3291a553cc62a4139b788e2e420e8c0 SHA512 bf00b8adaad7bd04077a83521b0d7accc26e644c8f3386819e7f91476178b6733f1c6554fb82dd0d3913398c83a61d65f61dc973f199f610bfaadc6251504819 WHIRLPOOL fe499ac7b4070581439a05f4f2245f7a42fe5630da5dc32b9b069511ed1faa15fe482eee08d50477d3fb1d0bf0d3855a69fc82fb0f3e8eecdf082fb642519f91
diff --git a/app-admin/ulogd/ulogd-2.0.4-r1.ebuild b/app-admin/ulogd/ulogd-2.0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..a49fa02
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils linux-info readme.gentoo systemd user
+
+DESCRIPTION="A userspace logging daemon for netfilter/iptables related logging"
+HOMEPAGE="http://netfilter.org/projects/ulogd/index.html"
+SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.bz2
+               http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86"
+IUSE="dbi doc json mysql nfacct +nfct +nflog pcap postgres sqlite"
+
+RDEPEND="net-firewall/iptables
+       >=net-libs/libnfnetlink-1.0.1
+       dbi? ( dev-db/libdbi )
+       json? ( dev-libs/jansson )
+       nfacct? (
+               >=net-libs/libmnl-1.0.3
+               >=net-libs/libnetfilter_acct-1.0.1
+       )
+       nfct? ( >=net-libs/libnetfilter_conntrack-1.0.2 )
+       nflog? ( >=net-libs/libnetfilter_log-1.0.0 )
+       mysql? ( virtual/mysql )
+       pcap? ( net-libs/libpcap )
+       postgres? ( dev-db/postgresql:= )
+       sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+       doc? (
+               app-text/linuxdoc-tools
+               app-text/texlive-core
+               virtual/latex-base
+       )"
+
+PATCHES=( "${FILESDIR}/${P}-linux-headers-3.17-ipt_ulog.patch" )
+
+DOCS=( AUTHORS README TODO )
+DOC_CONTENTS="You must have at least one logging stack enabled to make ulogd work.
+Please edit example configuration located at /etc/ulogd.conf"
+
+pkg_setup() {
+       enewgroup ulogd
+       enewuser ulogd -1 -1 /var/log/ulogd ulogd
+
+       linux-info_pkg_setup
+
+       if kernel_is lt 2 6 14; then
+               die "ulogd2 requires kernel newer than 2.6.14"
+       fi
+
+       if kernel_is lt 2 6 18; then
+               ewarn
+               ewarn "You are using kernel older than 2.6.18"
+               ewarn "Some ulogd2 features may be unavailable"
+               ewarn
+       fi
+
+       if use nfacct && kernel_is lt 3 3 0; then
+               ewarn "NFACCT input plugin requires kernel newer than 3.3.0"
+       fi
+
+       if ! use nfacct && ! use nfct && ! use nflog && kernel_is gt 3 17 0; then
+               ewarn "ULOG target was removed since 3.17.0 kernel release"
+               ewarn "Consider enabling NFACCT, NFCT or NFLOG support"
+       fi
+}
+
+src_prepare() {
+       # - make all logs to be kept in a single dir /var/log/ulogd
+       # - place sockets in /run instead of /tmp
+       sed -i \
+               -e 's:var/log:var/log/ulogd:g' \
+               -e 's:tmp:run:g' \
+               ulogd.conf.in || die 'sed on ulogd.conf.in failed'
+
+       autotools-utils_src_prepare
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_with dbi)
+               $(use_with json jansson)
+               $(use_enable nfacct)
+               $(use_enable nfct)
+               $(use_enable nflog)
+               $(use_with mysql)
+               $(use_with pcap)
+               $(use_with postgres pgsql)
+               $(use_with sqlite)
+       )
+       autotools-utils_src_configure
+}
+
+src_compile() {
+       autotools-utils_src_compile
+
+       if use doc; then
+               # prevent access violations from generation of bitmap font files
+               export VARTEXFONTS="${T}"/fonts
+               emake -C doc
+       fi
+}
+
+src_install() {
+       autotools-utils_src_install
+       readme.gentoo_create_doc
+       prune_libtool_files --modules
+
+       if use doc; then
+               dohtml doc/${PN}.html
+               dodoc doc/${PN}.dvi doc/${PN}.txt doc/${PN}.ps
+       fi
+
+       use sqlite && dodoc doc/sqlite3.table
+       use mysql && dodoc doc/mysql-*.sql
+       use postgres && dodoc doc/pgsql-*.sql
+       doman ${PN}.8
+
+       insinto /etc
+       doins ${PN}.conf
+       fowners root:ulogd /etc/ulogd.conf
+       fperms 640 /etc/ulogd.conf
+
+       newinitd "${FILESDIR}/${PN}.init" ${PN}
+       systemd_dounit "${FILESDIR}/${PN}.service"
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+       diropts -o ulogd -g ulogd
+       keepdir /var/log/ulogd
+}