dev-python/setproctitle: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:35:05 +0000 (14:35 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:59:03 +0000 (14:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setproctitle/Manifest
dev-python/setproctitle/setproctitle-1.1.10.ebuild [deleted file]
dev-python/setproctitle/setproctitle-1.1.8.ebuild [deleted file]

index cc042b4715d4abedb6c43451fa630457bc3cf1a8..2d207050999121948b396c244e1f22690e693701 100644 (file)
@@ -1,2 +1 @@
 DIST setproctitle-1.1.10.tar.gz 24042 BLAKE2B acd4ef33ab2a200b5d102fe5ceb78df03deeee47eb5a3c7b50f0a44e095953e5a4e2230278b6b4a5010472e4a5a18b81accbff0461e3a642be478b880d98114e SHA512 c976c5b86f59bc6d0f840f495b8256813169d3d7b9edae70207a24d62e1240bfec954fdc4f67b429ae124e3dc74efd7193404785643a52b2d57b55028bb3c533
-DIST setproctitle-1.1.8.tar.gz 23208 BLAKE2B b77fdabe04b274e0dba2555b195267f57f1e52b82c523b1a690b5583eecc8ded90a35452f1c6ac15b5b082acc1c76dba973089bd9c11b4244a397f7fb1263168 SHA512 9d0ab8e65afd7e1ac019ea47995498dae1f82d8aebb333dfc4c953e745441cb9a8db942ad8417522d1f9a805bc50ad680f3a37cb4cbbd4214d261d4fed600b20
diff --git a/dev-python/setproctitle/setproctitle-1.1.10.ebuild b/dev-python/setproctitle/setproctitle-1.1.10.ebuild
deleted file mode 100644 (file)
index 0c482ce..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# pypy doesn't get started in test run. Still required by www-servers/gunicorn
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Allow customization of the process title"
-HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# Required for re-write of test suite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
-       # Make a nice html file
-       rst2html.py README.rst > README.html
-       # The README.rst will be duplicated in src_install
-       rm README.rst || die
-}
-
-python_test() {
-       # The suite via the Makefile appears to not cater to pypy
-       [[ ${EPYTHON} =~ pypy ]] && return
-
-       # prepare embedded executable
-       emake \
-               CC="$(tc-getCC)" \
-               PYINC="$(python_get_CFLAGS)" \
-               PYLIB="$(python_get_LIBS)" \
-               check
-}
diff --git a/dev-python/setproctitle/setproctitle-1.1.8.ebuild b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
deleted file mode 100644 (file)
index 9344613..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# pypy doesn't get started in test run. Still required by www-servers/gunicorn
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Allow customization of the process title"
-HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-DOCS=( HISTORY.rst README.rst )
-
-python_prepare_all() {
-       sed -i -e "/pyrun/s:%s'.*):'):" tests/*.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       cp -r -l tests "${BUILD_DIR}"/ || die
-
-       if [[ ${EPYTHON} == python3.* ]]; then
-               # Notes:
-               #   -W is not supported by python3.1
-               #   -n causes Python to write into hardlinked files
-               2to3 --no-diffs -w "${BUILD_DIR}"/tests/*.py || die
-       fi
-
-       cd "${BUILD_DIR}" || die
-
-       if [[ ${EPYTHON} =~ pypy ]]; then
-               # The suite via the Makefile appears to not cater to pypy
-               return
-       else
-               CPPFLAGS="${CPPFLAGS} $(python_get_CFLAGS)"
-               LDLIBS="$(python_get_LIBS)"
-       fi
-
-       # prepare embedded executable
-       emake tests/pyrun CC="$(tc-getCC)" \
-               CPPFLAGS="${CPPFLAGS}" \
-               LDLIBS="${LDLIBS}"
-
-       nosetests --verbose || die "Tests fail with ${EPYTHON}"
-}