games-util/lutris: Bump to version 0.5.1.2
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 26 Mar 2019 10:03:03 +0000 (11:03 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 26 Mar 2019 10:03:03 +0000 (11:03 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-util/lutris/Manifest
games-util/lutris/lutris-0.5.1.2.ebuild [new file with mode: 0644]

index 9282625760ab0906b7488c093dbc76b03b64d398..d89558c3c7a347cb063be5ff428efbcb32766d06 100644 (file)
@@ -1,2 +1,3 @@
 DIST lutris_0.5.0.1.tar.xz 1687904 BLAKE2B 646182416201dd4e2fc025b600e569d87821ff98f2fc37ca6029479b7b097466e47135694303f8fc242c4d2632d0b4ecf471919181cd45b095bbff6ba8d973d4 SHA512 a9bf51f388859873de0af43b800692327b098c83966b9e32bbca3ccc0397e1ce5018e751b8f9fef5e83d9de4d1b014e330ffe7d8ab253af7dd2379151297f1bb
+DIST lutris_0.5.1.2.tar.xz 1741512 BLAKE2B b6e5d698222d073cf8062235c17b972264a0063632c0e75076c0ac085fe4ada6c5640254c4d346463ca2e0bb60e9e84b189bda7c390b7db374f2fcee605de1c6 SHA512 e6eba2bde00f597d2985923a5151ad1b8cbbcfe69845448d53b1d41d8129b72c3d679894babd56f64a6190e2d2265a924bb93eb1c65b29037214674738481909
 DIST lutris_0.5.1.tar.xz 1740384 BLAKE2B fa9d35a96c38b8105e507b4e7d804f0ed79dd41b7abf906b52256e51b4ceaf1d0efca992d30de09ecd1fa470fa04fb9fe89f37076d1a0ed17f8d2fb4d4539d6b SHA512 edd0b7d2817a4ce39d606757335f35ce66d6bf7fb7251f907d02299cafe1cd2a0528aeb203c8b9b7ff9d7a59c40966c581fdfd2e7794ac92e7eb0bdd3f9e1d4d
diff --git a/games-util/lutris/lutris-0.5.1.2.ebuild b/games-util/lutris/lutris-0.5.1.2.ebuild
new file mode 100644 (file)
index 0000000..e10b3d1
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+       EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+       inherit git-r3
+else
+       SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+BDEPEND="
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+       app-arch/cabextract
+       app-arch/p7zip
+       app-arch/unrar
+       app-arch/unzip
+       dev-python/pillow[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       dev-python/python-evdev[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       gnome-base/gnome-desktop[introspection]
+       media-sound/fluid-soundfont
+       net-libs/libsoup
+       net-libs/webkit-gtk:4[introspection]
+       x11-apps/mesa-progs
+       x11-apps/xgamma
+       x11-apps/xrandr
+       x11-libs/gtk+:3[introspection]
+       x11-libs/libnotify
+"
+
+S="${WORKDIR}/${PN}"
+
+python_install_all() {
+       local DOCS=( AUTHORS README.rst docs/installers.rst )
+       distutils-r1_python_install_all
+}
+
+python_test() {
+       virtx nosetests -v || die
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+
+       # Quote README.rst
+       elog "Lutris installations are fully automated through scripts, which can"
+       elog "be written in either JSON or YAML. The scripting syntax is described"
+       elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+       elog "available online at lutris.net."
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}