dev-python/pydiff: EAPI=7 bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 19:57:39 +0000 (15:57 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 15 Oct 2019 15:57:55 +0000 (11:57 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/pydiff/pydiff-0.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pydiff/pydiff-0.2-r1.ebuild b/dev-python/pydiff/pydiff-0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..01cf57f
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Diffs two Python files at the bytecode level"
+HOMEPAGE="https://github.com/myint/pydiff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+python_test() {
+       "${PYTHON}" test_pydiff.py || die "Tests failed under ${EPYTHON}"
+}