sys-libs/glibc: revert "use -mno-sdata, not -fcommon, bug #723268"
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 16 May 2020 11:27:17 +0000 (12:27 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 16 May 2020 11:30:49 +0000 (12:30 +0100)
The underying linker failure cause is not just an overflow
but a functional difference in '_dl_sysinfo_break' symbol linkage.

'_dl_sysinfo_break' is defined as a function in assembly
but declared as a global 'common' variable. Making it non-common
actually breaks sysinfo handler which is expected to be called
without function descriptor indirection. As sysonfo handler
is called before rtld processed it's own relocations.

Let's revert back to -fcommon until we have better glibc fix.

This reverts commit 8ec720b67f38952a4b9c6054c6d8ef0fc79d0343.

Bug: https://bugs.gentoo.org/723268
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.30-r8.ebuild
sys-libs/glibc/glibc-2.31-r3.ebuild
sys-libs/glibc/glibc-9999.ebuild

index b6a794f3004e5f8b35e97b9e90b8368834ce96ee..0421d5e61db16df66776565ae2ad147d379f5ab0 100644 (file)
@@ -309,8 +309,7 @@ setup_target_flags() {
                        # Workaround GPREL22 overflow by slightly pessimizing global
                        # references to go via 64-bit relocations instead of 22-bit ones.
                        # This allows building glibc on ia64 without an overflow: #723268
-                       append-flags -mno-sdata
-                       :
+                       append-flags -fcommon
                ;;
                mips)
                        # The mips abi cannot support the GNU style hashes. #233233
index d297db2b26d5ed774850095c77187f643124b4a5..5580625ba6d0736528222ec5ebc1300c3349465b 100644 (file)
@@ -303,8 +303,7 @@ setup_target_flags() {
                        # Workaround GPREL22 overflow by slightly pessimizing global
                        # references to go via 64-bit relocations instead of 22-bit ones.
                        # This allows building glibc on ia64 without an overflow: #723268
-                       append-flags -mno-sdata
-                       :
+                       append-flags -fcommon
                ;;
                mips)
                        # The mips abi cannot support the GNU style hashes. #233233
index ccedec70c67847ad213979e92e6fa4e247de6178..2355e5bce34e017582dc21d38a8cf359b5e2cf60 100644 (file)
@@ -302,8 +302,7 @@ setup_target_flags() {
                        # Workaround GPREL22 overflow by slightly pessimizing global
                        # references to go via 64-bit relocations instead of 22-bit ones.
                        # This allows building glibc on ia64 without an overflow: #723268
-                       append-flags -mno-sdata
-                       :
+                       append-flags -fcommon
                ;;
                mips)
                        # The mips abi cannot support the GNU style hashes. #233233