use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 15:56:39 +0000 (15:56 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 15:56:39 +0000 (15:56 +0000)
Package-Manager: portage-2.1.2.3

games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.9.ebuild
games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild
games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild
games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild

index 4dbb64e5bce327db4b09d99ef4fc02aca067eb93..ed79f28228230d2417ada626f92c80a154ac7491 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.6 2006/05/29 21:10:32 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.7 2007/04/09 15:49:33 nyhm Exp $
 
 inherit eutils games
 
@@ -22,22 +22,26 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/GSsoft${PV}
 
 src_unpack() {
-       unrar x -idq "${DISTDIR}"/${A} || die
+       unpack ${A}
        cd "${S}"
-       sed -i 's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' Src/Linux/Makefile || die
-       epatch "${FILESDIR}"/${P}-gentoo.patch \
+       sed -i \
+               's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' \
+               Src/Linux/Makefile \
+               || die "sed failed"
+       epatch \
+               "${FILESDIR}"/${P}-gentoo.patch \
                "${FILESDIR}"/${P}-PIC.patch \
                "${FILESDIR}/${P}"-gcc41.patch
 }
 
 src_compile() {
        cd Src/Linux
-       emake OPTFLAGS="${CFLAGS}" || die "make failed"
+       emake OPTFLAGS="${CFLAGS}" || die "emake failed"
 }
 
 src_install() {
        dodoc ReadMe.txt
-       exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
-       newexe Src/Linux/libGSsoft.so libGSsoft-${PV}.so || die
+       exeinto "$(games_get_libdir)"/ps2emu/plugins
+       newexe Src/Linux/libGSsoft.so libGSsoft-${PV}.so || die "newexe failed"
        prepgamesdirs
 }
index faa6abf0cf9e0269669111df1e9130c598fcef13..0c11dc49c37cfaad409a67d43e2d8bd5f241c376 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.9.ebuild,v 1.4 2006/05/03 18:07:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.9.ebuild,v 1.5 2007/04/09 15:51:25 nyhm Exp $
 
 inherit eutils games
 
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/PADwin${PV//.}
 
 src_unpack() {
-       unrar x -idq "${DISTDIR}"/${A} || die
+       unpack ${A}
        cd "${S}"
        sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' Src/Makefile || die
        epatch "${FILESDIR}/${P}"-gcc41.patch
@@ -33,7 +33,7 @@ src_compile() {
 
 src_install() {
        dodoc ReadMe.txt
-       exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+       exeinto "$(games_get_libdir)"/ps2emu/plugins
        newexe Src/libPADwin.so libPADxwin-${PV}.so || die
        prepgamesdirs
 }
index ccaab5289c557a68d095992c0c37d79adb94dfff..d568801f60eb360d10568f85fdfeee493c5fa0cb 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild,v 1.2 2005/08/07 07:36:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild,v 1.3 2007/04/09 15:52:52 nyhm Exp $
 
 inherit games
 
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/SPU2null${PV//.}
 
 src_unpack() {
-       unrar x -idq "${DISTDIR}"/${A} || die
+       unpack ${A}
        cd "${S}"
        sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' Src/Makefile || die
 }
@@ -32,7 +32,7 @@ src_compile() {
 
 src_install() {
        dodoc ReadMe.txt
-       exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+       exeinto "$(games_get_libdir)"/ps2emu/plugins
        newexe Src/libSPU2null.so libSPU2null-${PV//.}.so || die
        prepgamesdirs
 }
index 25caa50a74296da61170de21de741c1bb4699009..985cff378ce0a2baf7bbd2c4ca136f70638d1392 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild,v 1.3 2006/09/26 18:43:45 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild,v 1.4 2007/04/09 15:54:33 nyhm Exp $
 
 inherit games
 
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/USBnull${PV//.}
 
 src_unpack() {
-       unrar x -idq "${DISTDIR}"/${A} || die
+       unpack ${A}
        cd "${S}"
        sed -i \
                -e 's:-O3 -fomit-frame-pointer:$(OPTFLAGS):' \
@@ -35,9 +35,9 @@ src_compile() {
 
 src_install() {
        dodoc ReadMe.txt
-       exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+       exeinto "$(games_get_libdir)"/ps2emu/plugins
        newexe Linux/libUSBnull.so libUSBnull-${PV//.}.so || die
-       exeinto "${GAMES_LIBDIR}"/ps2emu/cfg
+       exeinto "$(games_get_libdir)"/ps2emu/cfg
        doexe Linux/cfgUSBnull || die
        prepgamesdirs
 }
index dde9eb04c7cfbbbf91f508df53775efc0efb36f6..1c4540c393b572d09922e2d7f55423b308542007 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild,v 1.8 2006/09/26 18:32:03 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild,v 1.9 2007/04/09 15:56:39 nyhm Exp $
 
 inherit eutils games
 
@@ -30,11 +30,11 @@ src_compile() {
 }
 
 src_install() {
-       exeinto "${GAMES_LIBDIR}"/psemu/plugins
+       exeinto "$(games_get_libdir)"/psemu/plugins
        doexe src/libcdr-* || die "doexe failed (1)"
-       exeinto "${GAMES_LIBDIR}"/psemu/cfg
+       exeinto "$(games_get_libdir)"/psemu/cfg
        doexe src/cfg-gtk*/cfgCdr || die "doexe failed(2)"
-       insinto "${GAMES_LIBDIR}"/psemu/cfg
+       insinto "$(games_get_libdir)"/psemu/cfg
        doins cdr.cfg || die "doins failed"
        dodoc ReadMe.txt
        prepgamesdirs