dev-python/pyzmq: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 06:42:32 +0000 (07:42 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:39:45 +0000 (10:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyzmq/pyzmq-16.0.2.ebuild
dev-python/pyzmq/pyzmq-17.1.0.ebuild

index 914737e0cb2b70a5ab9ca5cef03552e5911d0c7b..3d7f27c1de1a56c89a8b0d7b17b69244fcf4ab16 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
        >=net-libs/zeromq-4.1.2:=
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                www-servers/tornado[${PYTHON_USEDEP}]
        )
        doc? (
index 90216948f4ff7562d5d861d9ac8577e560174a6f..f35f0255f6ca796834222c47f1497569059eabe2 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
        >=net-libs/zeromq-4.2.2-r2:=[drafts]
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
        )
        doc? (