Don't ignore CVS/Entries.IO_error when not in commit mode. (trunk r15272) v2.1.7.17
authorZac Medico <zmedico@gentoo.org>
Fri, 29 Jan 2010 19:07:56 +0000 (19:07 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 29 Jan 2010 19:07:56 +0000 (19:07 -0000)
svn path=/main/branches/2.1.7/; revision=15273

bin/repoman

index 7efd7e7ecf847da9c22f21139e3768bd07181df0..c84079555e20af25eb6fbffa0a2db90a1e48f7f2 100755 (executable)
@@ -1157,12 +1157,11 @@ for x in scanlist:
                                                if l[-7:] == ".ebuild":
                                                        eadded.append(os.path.basename(l[:-7]))
                except IOError:
-                       if options.mode == 'commit':
-                               if vcs == "cvs":
-                                       stats["CVS/Entries.IO_error"] += 1
-                                       fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
-                               else:
-                                       raise
+                       if vcs == "cvs":
+                               stats["CVS/Entries.IO_error"] += 1
+                               fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
+                       else:
+                               raise
                        continue
 
        mf = Manifest(checkdir, repoman_settings["DISTDIR"])