sys-apps/util-linux: fix pam file installation
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 26 Feb 2017 03:30:42 +0000 (21:30 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 26 Feb 2017 03:30:58 +0000 (21:30 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-apps/util-linux/util-linux-2.29.2-r1.ebuild

index a4dccc6ab0b21ffdf195fc2eb30e816986446c30..f57dfef1b83182e363568e7cac99455ed7a36a08 100644 (file)
@@ -6,7 +6,7 @@ EAPI="5"
 PYTHON_COMPAT=( python2_7 python3_{4,5} )
 
 inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 \
-       python-single-r1 multilib-minimal systemd
+       pam python-single-r1 multilib-minimal systemd
 
 MY_PV=${PV/_/-}
 MY_P=${PN}-${MY_PV}
@@ -181,8 +181,8 @@ multilib_src_install_all() {
        prune_libtool_files
 
        if use pam; then
-               dopamd "${FILESDIR}/runuser.pamd" runuser
-               dopamd "${FILESDIR}/runuser-l.pamd" runuser-l
+               newpamd "${FILESDIR}/runuser.pamd" runuser
+               newpamd "${FILESDIR}/runuser-l.pamd" runuser-l
        fi
 }