dev-python/discogs-client: Remove old (drop to ~arch)
authorMichał Górny <mgorny@gentoo.org>
Wed, 5 Feb 2020 05:27:19 +0000 (06:27 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 5 Feb 2020 05:50:07 +0000 (06:50 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/discogs-client/Manifest
dev-python/discogs-client/discogs-client-2.0.2.ebuild [deleted file]

index 54142071af5bf7a61c921df343904f58d2d81715..95b4f68be814467bab09769d4a43e01c5ca42a89 100644 (file)
@@ -1,2 +1 @@
-DIST discogs-client-2.0.2.tar.gz 25486 BLAKE2B f901628a74b2df091e40eb3e5f5ef8a7300fbb9e372d044580f3b13b524b477e427feaf4cd5287d9782efed82032b93ed9c26071de7ec49e308c7bfdc7aa5e78 SHA512 00634eb95018ccb2ece0adf4b7e3ea96674f0c8dd63d9bd151cdf9c871898fa24379f78065ebb677cc87eaffa31e91ba60051622a38c6bd774e010c20229b16e
 DIST discogs-client-2.2.1.tar.gz 24645 BLAKE2B 310b2a23a58f58c0d258599ad88a8e44202a38850af72ead293bd5ac21a92521ee53cfd6d8340d4c122145b4f3797f905a7f5273c6b0e5e23e8aff43fdf09c85 SHA512 fa339b14d5655a36fdf252fd94c729ecb97e195c1f7eb2e5207355dc5f4fd89d0b738218ffbac71acab4f143870bdba5cf5ea02dff70166014f14c30481ae1e5
diff --git a/dev-python/discogs-client/discogs-client-2.0.2.ebuild b/dev-python/discogs-client/discogs-client-2.0.2.ebuild
deleted file mode 100644 (file)
index dfb505c..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# Not py3 capable due to oauth2 supports py2 pypy only
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Official Python API client for Discogs"
-HOMEPAGE="https://github.com/discogs/discogs_client https://pypi.org/project/discogs-client/"
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/discogs/${PN/-/_}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
-               dev-python/oauth2[${PYTHON_USEDEP}]"
-# It's either this or make a test use flag to add RDEPEND behind it. Both work
-DEPEND="${RDEPEND}
-               dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"/${P/-/_}
-
-python_test() {
-       "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}