dev-dotnet/ndesk-dbus: Fix compat with mono-4
authorPacho Ramos <pacho@gentoo.org>
Sun, 9 Oct 2016 08:41:20 +0000 (10:41 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 9 Oct 2016 09:03:36 +0000 (11:03 +0200)
Package-Manager: portage-2.3.1

dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild

index b7d6156088e7ebcdc76010eaabc71104c08a8b48..92da367a088de833424ad98eb0668e631b5c50db 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-inherit mono
+EAPI=6
+inherit mono-env
 
 DESCRIPTION="Managed D-Bus Implementation for .NET"
 HOMEPAGE="http://www.ndesk.org/DBusSharp"
@@ -13,12 +14,16 @@ SLOT="0"
 KEYWORDS="amd64 ppc x86"
 IUSE=""
 
-RDEPEND=">=dev-lang/mono-1.2.4
-       >=sys-apps/dbus-1"
+RDEPEND="
+       >=dev-lang/mono-1.2.4
+       >=sys-apps/dbus-1
+"
 DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+       virtual/pkgconfig
+"
 
-src_install() {
-       emake DESTDIR="${D}" install || die "emake install failed."
-       dodoc AUTHORS README
+src_prepare() {
+       default
+       # mono-4 compat
+       sed -i "s#gmcs#mcs#g" configure
 }