sys-devel/prelink: Use EAPI="7".
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Mon, 6 Apr 2020 01:09:27 +0000 (01:09 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 6 Apr 2020 20:30:39 +0000 (21:30 +0100)
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/prelink/prelink-20151030.ebuild

index 6c1b59681b7bb14b1d2f96e650cdbe72c9b01799..e119ab02ea9396a394126eedcd4de9ee6c598d27 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 2002-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI="7"
 
 MY_PN="${PN}-cross"
 MY_P="${MY_PN}-${PV}"
 
-inherit autotools eutils flag-o-matic
+inherit autotools flag-o-matic
 
 DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
 HOMEPAGE="https://git.yoctoproject.org/cgit/cgit.cgi/prelink-cross/ https://people.redhat.com/jakub/prelink"
@@ -26,9 +26,13 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${MY_P}
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
+       "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
+)
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
-       epatch "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
+       default
 
        sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147