sys-devel/llvm-common: Port 9+ to llvm.org.eclass
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 17:37:46 +0000 (18:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 11:46:08 +0000 (12:46 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
sys-devel/llvm-common/llvm-common-9.0.0.ebuild
sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild

index 7edf27153de4417796328fd4a420bdec1f32bd4f..ba2ffc76a7067e480ab90cd57edc98e849302dae 100644 (file)
@@ -3,13 +3,12 @@
 
 EAPI=7
 
-inherit git-r3
+inherit llvm.org
 
 DESCRIPTION="Common files shared between multiple slots of LLVM"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -18,19 +17,10 @@ IUSE=""
 
 RDEPEND="!sys-devel/llvm:0"
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' llvm/utils/vim
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
        insinto /usr/share/vim/vimfiles
-       doins -r utils/vim/*/
+       doins -r */
        # some users may find it useful
-       newdoc utils/vim/README README.vim
-       dodoc utils/vim/vimrc
+       newdoc README README.vim
+       dodoc vimrc
 }
index 65eb4d232e338a5cbf2124004b4eeee43cbde6ef..a81f8f505994211779feb82f631c7053880e8e03 100644 (file)
@@ -3,11 +3,12 @@
 
 EAPI=7
 
-MY_P=llvm-${PV/_/}.src
+inherit llvm.org
+
 DESCRIPTION="Common files shared between multiple slots of LLVM"
 HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -16,19 +17,10 @@ IUSE=""
 
 RDEPEND="!sys-devel/llvm:0"
 
-src_unpack() {
-       einfo "Unpacking parts of ${MY_P}.tar.xz ..."
-       tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/vim" || die
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
        insinto /usr/share/vim/vimfiles
-       doins -r utils/vim/*/
+       doins -r */
        # some users may find it useful
-       newdoc utils/vim/README README.vim
-       dodoc utils/vim/vimrc
+       newdoc README README.vim
+       dodoc vimrc
 }
index b3b79ac4e6c670c04690a15cbc483fdac0a14d5d..ba2ffc76a7067e480ab90cd57edc98e849302dae 100644 (file)
@@ -3,14 +3,12 @@
 
 EAPI=7
 
-inherit git-r3
+inherit llvm.org
 
 DESCRIPTION="Common files shared between multiple slots of LLVM"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -19,19 +17,10 @@ IUSE=""
 
 RDEPEND="!sys-devel/llvm:0"
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' llvm/utils/vim
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
        insinto /usr/share/vim/vimfiles
-       doins -r utils/vim/*/
+       doins -r */
        # some users may find it useful
-       newdoc utils/vim/README README.vim
-       dodoc utils/vim/vimrc
+       newdoc README README.vim
+       dodoc vimrc
 }