app-arch/lha: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Tue, 12 Nov 2019 15:21:48 +0000 (10:21 -0500)
committerAaron Bauman <bman@gentoo.org>
Tue, 12 Nov 2019 15:21:48 +0000 (10:21 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-arch/lha/lha-114i-r7.ebuild [deleted file]
app-arch/lha/lha-114i-r8.ebuild [deleted file]

diff --git a/app-arch/lha/lha-114i-r7.ebuild b/app-arch/lha/lha-114i-r7.ebuild
deleted file mode 100644 (file)
index dcf54bb..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit autotools eutils flag-o-matic
-
-MY_P=${PN}-1.14i-ac20050924p1
-
-DESCRIPTION="Utility for creating and opening lzh archives"
-HOMEPAGE="http://lha.sourceforge.jp"
-SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
-
-LICENSE="lha"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-file-list-from-stdin.patch
-
-       sed -i -e '/^AM_C_PROTOTYPES/d' configure.ac || die #423125
-
-       eautoreconf
-}
-
-src_configure() {
-       append-cppflags -DPROTOTYPES #423125
-
-       if [[ ${CHOST} == *-interix* ]]; then
-               export ac_cv_header_inttypes_h=no
-               export ac_cv_func_iconv=no
-       fi
-
-       econf
-}
-
-src_install() {
-       emake \
-               DESTDIR="${D}" \
-               mandir="${EPREFIX}"/usr/share/man/ja \
-               install
-
-       dodoc ChangeLog Hacking_of_LHa
-}
diff --git a/app-arch/lha/lha-114i-r8.ebuild b/app-arch/lha/lha-114i-r8.ebuild
deleted file mode 100644 (file)
index b9e27d7..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic
-
-MY_P=${PN}-1.14i-ac20050924p1
-
-DESCRIPTION="Utility for creating and opening lzh archives"
-HOMEPAGE="http://lha.sourceforge.jp"
-SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
-LICENSE="lha"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-file-list-from-stdin.patch
-       "${FILESDIR}"/${P}-fix-getopt_long-declaration.patch
-)
-
-src_prepare() {
-       epatch "${PATCHES[@]}"
-
-       sed -e '/^AM_C_PROTOTYPES/d' \
-               -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
-               -i configure.ac || die #423125, 467544
-
-       eautoreconf
-}
-
-src_configure() {
-       append-cppflags -DPROTOTYPES #423125
-
-       if [[ ${CHOST} == *-interix* ]]; then
-               export ac_cv_header_inttypes_h=no
-               export ac_cv_func_iconv=no
-       fi
-
-       econf
-}
-
-src_install() {
-       emake \
-               DESTDIR="${D}" \
-               mandir="${EPREFIX}"/usr/share/man/ja \
-               install
-
-       dodoc ChangeLog Hacking_of_LHa
-}