gnome-extra/cinnamon: fix build with clutter[-gtk]
authorAlexandre Rostovtsev <tetromino@gentoo.org>
Sun, 6 Sep 2015 21:54:59 +0000 (17:54 -0400)
committerAlexandre Rostovtsev <tetromino@gentoo.org>
Sun, 6 Sep 2015 21:54:59 +0000 (17:54 -0400)
Gentoo-Bug: 559794
Reported-by: Lara Maia
Upstream-Bug-url: https://github.com/linuxmint/Cinnamon/pull/4600

Package-Manager: portage-2.2.20.1

gnome-extra/cinnamon/cinnamon-2.6.13.ebuild
gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch [new file with mode: 0644]

index 76f706b0a8ea266848bcdc695bfeccd77da93a62..5f1d5367920d928a7fde11890f1613de8fe19775 100644 (file)
@@ -160,6 +160,10 @@ src_prepare() {
        # https://github.com/linuxmint/Cinnamon/issues/3577
        epatch "${FILESDIR}"/${PN}-2.4.5-gnome-3.14.patch
 
+       # Fix build with clutter[-gtk]
+       # https://github.com/linuxmint/Cinnamon/pull/4600
+       epatch "${FILESDIR}"/${PN}-2.6.13-test-recorder-includes.patch
+
        # Use pkexec instead of gksu (from Arch)
        # https://github.com/linuxmint/Cinnamon/issues/3565
        sed -i 's/gksu/pkexec/' files/usr/bin/cinnamon-settings-users || die
diff --git a/gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch b/gnome-extra/cinnamon/files/cinnamon-2.6.13-test-recorder-includes.patch
new file mode 100644 (file)
index 0000000..3ed2c3a
--- /dev/null
@@ -0,0 +1,36 @@
+From cf960f096e426521fc898733580d47c725e52953 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 6 Sep 2015 14:53:48 -0400
+Subject: [PATCH] build: append ST_CFLAGS when building test-recorder
+
+test-recorder #includes st.h, which pulls in lots of headers, some of which
+might not be in TEST_CINNAMON_RECORDER_CFLAGS, depending on how clutter and
+gstreamer were configured.
+
+Fixes build failure reported at https://bugs.gentoo.org/559794 :
+
+In file included from ./st/st-bin.h:27:0,
+                 from st.h:4,
+                 from cinnamon-recorder.c:19:
+./st/st-types.h:26:21: fatal error: gtk/gtk.h: No such file or directory
+---
+ src/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3d8fdd3..e6e54a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -199,7 +199,8 @@ libcinnamon_la_SOURCES += $(cinnamon_recorder_sources) $(cinnamon_recorder_non_g
+ noinst_PROGRAMS += test-recorder
+-test_recorder_CPPFLAGS = $(TEST_CINNAMON_RECORDER_CFLAGS)
++test_recorder_CPPFLAGS = $(TEST_CINNAMON_RECORDER_CFLAGS) \
++                       $(ST_CFLAGS)
+ test_recorder_LDADD = $(TEST_CINNAMON_RECORDER_LIBS) \
+                        libst-1.0.la
+-- 
+2.5.1
+