dev-python/stevedore: 1.30.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 03:09:55 +0000 (22:09 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:30 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/stevedore/Manifest
dev-python/stevedore/stevedore-1.30.1.ebuild [new file with mode: 0644]

index 9d8d4000e76396c99763788f0c595e1073b6d202..9a1eb681a3beb7fbcb173669ebfe39d95cafee12 100644 (file)
@@ -1,2 +1,3 @@
 DIST stevedore-1.25.1.tar.gz 509014 BLAKE2B 22580ac0e5af56eadd81e7521888e3b2458a1c03a3bdac69df1f2eeef20248f1ddc1748447e3e961b61cbe62ebc939e36c04ff011b7845b3278e18a5fdc9e14e SHA512 f3d2a7360e783c800c3c2488f6adf6f9f76e34e4a4e6f3fc53d2f1114b889c443c13fdf217ddce65a41922dda2c782f19b2077847807c70e732a522fd2166ff0
 DIST stevedore-1.28.0.tar.gz 504872 BLAKE2B 6a9ba88ab950f17898d2dd76d75cd7bc7031cbcf441523863520e15916bc5c255fe6a62444f46b6d9967ec1f5f716420b36cb114995907ec8e2c39110ae7918a SHA512 e148560e255a362a51ce91e8bc2380828ba9a41e1988138bcff2d5b270097cadffdee30f3c98e123d8ced9f6f0ff350b52e793fd400ce6b45095860788bd6b86
+DIST stevedore-1.30.1.tar.gz 507795 BLAKE2B 92af8ac52dd28d765df32bd127d76aed0d0d66e2a4edc772aecb35ae78b52e9091203991a457be732d62a2987cc378d0c62cdd94898ad7e41f33b320401d4fa9 SHA512 3316ba9c73dc5499588a65fb0abc85ffc8eeea14dc94fbaced6379246098f03201d8a13dc64510a0840cb3d266ac83ffbb957738a61ee2a36440611833bab4ef
diff --git a/dev-python/stevedore/stevedore-1.30.1.ebuild b/dev-python/stevedore/stevedore-1.30.1.ebuild
new file mode 100644 (file)
index 0000000..4e7be7d
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+               !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+               !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       # Delete spurious data in requirements.txt
+       sed -e '/^pbr/d' -i requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+}