app-editors/amyedit: Fix building with latest glibmm/libsigc++
authorPacho Ramos <pacho@gentoo.org>
Wed, 23 Dec 2015 10:14:29 +0000 (11:14 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 23 Dec 2015 10:58:32 +0000 (11:58 +0100)
Package-Manager: portage-2.2.26

app-editors/amyedit/amyedit-1.0-r2.ebuild

index 4e47fcfa4102baa33106f9887b30d44050a3c7fe..86575b0e01afa22d392d30e7e93c6dce53bca8af 100644 (file)
@@ -2,9 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=3
-
-inherit eutils autotools
+EAPI=5
+inherit autotools eutils flag-o-matic
 
 DESCRIPTION=" AmyEdit is a LaTeX editor"
 HOMEPAGE="http://amyedit.sf.net"
@@ -29,10 +28,7 @@ src_prepare() {
        epatch "${FILESDIR}/${P}-gcc45.patch"
        epatch "${FILESDIR}/${P}-sourceviewmm2.patch"
        rm -rf "${S}/src/gtksourceviewmm" || die
+       append-cxxflags -std=c++11
+       mv configure.in configure.ac || die
        eautoreconf
 }
-
-src_install() {
-       emake DESTDIR="${D}" install || die
-       dodoc ChangeLog README TODO || die
-}