dev-python/cli_helpers: Bump to 2.0.0
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:25:11 +0000 (08:25 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:03:15 +0000 (09:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cli_helpers/Manifest
dev-python/cli_helpers/cli_helpers-2.0.0.ebuild [new file with mode: 0644]

index ab47dcb5b66531c7629193022e481f9b33da0629..ac6947078589a1fc4875447c112b8fde6d4fb684 100644 (file)
@@ -1 +1,2 @@
 DIST cli_helpers-1.2.1.tar.gz 31104 BLAKE2B ded2b9b7825ddaeb33acf64b65362251f773a4a0a74aec1c79bdd8ef77f8f6953dd8761fd926f7a2b210c69534bee220f88e816dd63277b27db15b400510c9f3 SHA512 299fa4984b7c76e6be0527f040582242a746938f8725b6193895f9bbb835c82078658bbb8d1ea0000c26f3c8d2dad93139fd600e7c8d7c2d89777de27a5b26cf
+DIST cli_helpers-2.0.0.tar.gz 31320 BLAKE2B dbda2c7128ac7a5f21ce9f12f866cffde1be9a4bb422c1233b32d9f346c54a73df5e5ea7734cb64ca13f3aeec7c11678c8090499cb5aa4b6d385c4fbc394f8e9 SHA512 fadee3d356d5a687d2f618801f31d0cd4b6c9a4ea1fad4d5fed087a95c3343ab90622e6c246d9a3bd878bc8324d3e9b3626ed3f1436c5d68698562ff6abec3a5
diff --git a/dev-python/cli_helpers/cli_helpers-2.0.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..0de3c18
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+       >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+       dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               >=dev-python/mock-2[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}