app-emulation/xen: fix efi path
authorTomas Mozes <hydrapolic@gmail.com>
Mon, 16 Dec 2019 08:51:21 +0000 (09:51 +0100)
committerYixun Lan <dlan@gentoo.org>
Tue, 17 Dec 2019 16:35:36 +0000 (16:35 +0000)
Closes: https://bugs.gentoo.org/703050
Closes: https://github.com/gentoo/gentoo/pull/13996
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Signed-off-by: Yixun Lan <dlan@gentoo.org>
app-emulation/xen/xen-4.12.1-r4.ebuild
app-emulation/xen/xen-4.13.0_rc4.ebuild

index 3ee8dd94a9cec8ef927274a6942161f7205848c3..a2e48e0d1116d3efc4a0e1649a378819c9689936 100644 (file)
@@ -105,7 +105,7 @@ src_prepare() {
 
        if use efi; then
                export EFI_VENDOR="gentoo"
-               export EFI_MOUNTPOINT="boot"
+               export EFI_MOUNTPOINT="/boot"
        fi
 
        default
@@ -148,7 +148,7 @@ pkg_postinst() {
        elog "Official Xen Guide:"
        elog " https://wiki.gentoo.org/wiki/Xen"
 
-       use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+       use efi && einfo "The efi executable is installed in /boot/efi/gentoo"
 
        elog "You can optionally block the installation of /boot/xen-syms by an entry"
        elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
index c18edd05ce4ae7248d5465458e2f29b18e035bc5..334affd09a8834bf974f7252f5f9d4b306fb02b0 100644 (file)
@@ -106,7 +106,7 @@ src_prepare() {
 
        if use efi; then
                export EFI_VENDOR="gentoo"
-               export EFI_MOUNTPOINT="boot"
+               export EFI_MOUNTPOINT="/boot"
        fi
 
        default
@@ -147,7 +147,7 @@ pkg_postinst() {
        elog "Official Xen Guide:"
        elog " https://wiki.gentoo.org/wiki/Xen"
 
-       use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+       use efi && einfo "The efi executable is installed in /boot/efi/gentoo"
 
        elog "You can optionally block the installation of /boot/xen-syms by an entry"
        elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"