media-sound/qsampler-9999: added live ebuild
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 11:27:12 +0000 (12:27 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 11:27:12 +0000 (12:27 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/qsampler/qsampler-9999.ebuild [new file with mode: 0644]

diff --git a/media-sound/qsampler/qsampler-9999.ebuild b/media-sound/qsampler/qsampler-9999.ebuild
new file mode 100644 (file)
index 0000000..097079e
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils autotools xdg subversion
+
+DESCRIPTION="Graphical frontend to the LinuxSampler engine"
+HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
+ESVN_REPO_URI="https://svn.linuxsampler.org/svn/qsampler/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +libgig"
+
+COMMON_DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       media-libs/alsa-lib
+       >=media-libs/liblscp-0.5.6:=
+       x11-libs/libX11
+       libgig? ( >=media-libs/libgig-3.3.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+       >=media-sound/linuxsampler-0.5
+"
+DEPEND="${COMMON_DEPEND}
+       dev-qt/linguist-tools:5
+"
+
+DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.3-Makefile.patch" )
+
+src_prepare() {
+       default
+
+       emake -f Makefile.svn
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+               $(use_enable libgig)
+       )
+       ac_qmake="$(qt5_get_bindir)/qmake" \
+               econf "${myeconfargs[@]}"
+
+       cd src || die
+       eqmake5 src.pro -o Makefile
+}