dev-ruby/did_you_mean: avoid broken test
authorHans de Graaff <graaff@gentoo.org>
Sat, 17 Nov 2018 07:08:32 +0000 (08:08 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sat, 17 Nov 2018 07:12:11 +0000 (08:12 +0100)
Fixes: https://bugs.gentoo.org/671120
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/did_you_mean/did_you_mean-1.1.2.ebuild

index bd875176b602acb0cc8565c3373ac0165d76b230..3656e938bba8ac139f5c9775e38bdbce7a7c9b48 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -19,4 +19,7 @@ IUSE=""
 
 all_ruby_prepare() {
        sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+       # Skip test that is broken with newer ruby releases
+       sed -i -e  '/test_message/,/^  end/ s:^:#:' test/core_ext/name_error_extension_test.rb || die
 }