dev-python/mako: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 17:31:40 +0000 (18:31 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 18:09:28 +0000 (19:09 +0100)
Closes: https://bugs.gentoo.org/709958
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/mako/mako-1.1.0.ebuild

index c993bccace2a211542132a1bb168440373fc3381..69a811c5789c434c72de549bd5470a720bc8aeaa 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
 
 inherit distutils-r1 eutils
@@ -23,7 +24,6 @@ RESTRICT="!test? ( test )"
 RDEPEND=">=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                ${RDEPEND}
                $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' pypy python2_7)