media-video/imagination: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:40 +0000 (14:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:40 +0000 (14:20 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-video/imagination/files/imagination-3.0-enable-translations.patch [new file with mode: 0644]
media-video/imagination/files/imagination-3.0-fix-htmldir.patch [new file with mode: 0644]
media-video/imagination/imagination-3.0-r1.ebuild

diff --git a/media-video/imagination/files/imagination-3.0-enable-translations.patch b/media-video/imagination/files/imagination-3.0-enable-translations.patch
new file mode 100644 (file)
index 0000000..d829129
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/support.h
++++ b/src/support.h
+@@ -20,7 +20,7 @@
+ #ifndef __IMAGINATION_SUPPORT_H
+ #define __IMAGINATION_SUPPORT_H
+-#define PLUGINS_INSTALLED 0
++#define PLUGINS_INSTALLED 1
+ #ifdef HAVE_CONFIG_H
+ #  include <config.h>
diff --git a/media-video/imagination/files/imagination-3.0-fix-htmldir.patch b/media-video/imagination/files/imagination-3.0-fix-htmldir.patch
new file mode 100644 (file)
index 0000000..14e6f3a
--- /dev/null
@@ -0,0 +1,95 @@
+--- a/doc/en/images/Makefile.am
++++ b/doc/en/images/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+-imagesdir = $(datadir)/doc/imagination/html/en/images
++imagesdir = $(htmldir)/en/images
+ images_DATA = \
+                               imagination_window.png \
+                               side_panel_video.png   \
+--- a/doc/en/Makefile.am
++++ b/doc/en/Makefile.am
+@@ -3,7 +3,7 @@
+ SUBDIRS =                                                             \
+       images
+-TARGET_DIR = $(datadir)/doc/imagination/html/en
++TARGET_DIR = $(htmldir)/en
+ STYLESHEET = ../imagination.xsl
+ DOCUMENT = imagination.xml
+--- a/doc/es/images/Makefile.am
++++ b/doc/es/images/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+-imagesdir = $(datadir)/doc/imagination/html/es/images
++imagesdir = $(htmldir)/es/images
+ images_DATA = \
+                               imagination_window.png \
+                               side_panel_video.png   \
+--- a/doc/es/Makefile.am
++++ b/doc/es/Makefile.am
+@@ -3,7 +3,7 @@
+ SUBDIRS =                                                             \
+       images
+-TARGET_DIR = $(datadir)/doc/imagination/html/es
++TARGET_DIR = $(htmldir)/es
+ STYLESHEET = ../imagination.xsl
+ DOCUMENT = imagination.xml
+--- a/doc/fr/images/Makefile.am
++++ b/doc/fr/images/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+-imagesdir = $(datadir)/doc/imagination/html/fr/images
++imagesdir = $(htmldir)/fr/images
+ images_DATA = \
+                               imagination_window.png \
+                               side_panel_video.png   \
+--- a/doc/fr/Makefile.am
++++ b/doc/fr/Makefile.am
+@@ -3,7 +3,7 @@
+ SUBDIRS =                                                             \
+       images
+-TARGET_DIR = $(datadir)/doc/imagination/html/fr
++TARGET_DIR = $(htmldir)/fr
+ STYLESHEET = ../imagination.xsl
+ DOCUMENT = imagination.xml
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,7 +1,7 @@
+ SUBDIRS =                                                     \
+       en es fr pt_BR
+-cssdir = $(datadir)/doc/imagination/html
++cssdir = $(htmldir)
+ css_DATA =                                                    \
+       imagination.css
+       
+--- a/doc/pt_BR/images/Makefile.am
++++ b/doc/pt_BR/images/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+-imagesdir = $(datadir)/doc/imagination/html/pt_BR/images
++imagesdir = $(htmldir)/pt_BR/images
+ images_DATA = \
+                               imagination_window.png \
+                               side_panel_video.png   \
+--- a/doc/pt_BR/Makefile.am
++++ b/doc/pt_BR/Makefile.am
+@@ -3,7 +3,7 @@
+ SUBDIRS =                                                             \
+       images
+-TARGET_DIR = $(datadir)/doc/imagination/html/pt_BR
++TARGET_DIR = $(htmldir)/pt_BR
+ STYLESHEET = ../imagination.xsl
+ DOCUMENT = imagination.xml
index 030aa01ae12520ff78a8cbf996ab65a48a81c0f0..dbf5d971be688f42b0501d808cdb40a1192ba8af 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=7
 
-inherit autotools eutils
+inherit autotools desktop
 
 DESCRIPTION="Simple DVD slideshow maker"
 HOMEPAGE="http://imagination.sourceforge.net/"
@@ -13,29 +13,29 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
-DEPEND="x11-libs/gtk+:2
-       media-sound/sox"
+DEPEND="
+       media-sound/sox:=
+       x11-libs/cairo:=
+       x11-libs/gtk+:2"
 RDEPEND="${DEPEND}
        virtual/ffmpeg"
 
-LANGS="cs de en_GB fr it pt_BR sv zh_CN zh_TW"
+PATCHES=(
+       "${FILESDIR}"/${P}-cflags.patch
+       "${FILESDIR}"/${P}-enable-translations.patch
+       "${FILESDIR}"/${P}-fix-htmldir.patch
+)
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-cflags.patch
-       # enable translations. Bug #380011
-       sed -i -e "/#define PLUGINS_INSTALLED/s:0:1:" "${S}"/src/support.h || die
-       rm "${S}"/po/LINGUAS
-       for x in ${LANGS}; do
-               if ! has ${x} ${LINGUAS}; then
-                       rm "${S}"/po/${x}.po || die
-               else
-                       echo -n "${x} " >> "${S}"/po/LINGUAS
-               fi
-       done
+       default
+       mv configure.{in,ac} || die
        eautoreconf
 }
 
 src_install() {
        default
        doicon icons/48x48/${PN}.png
+
+       # only plugins
+       find "${D}" -name '*.la' -delete || die
 }