net-irc/kvirc: Add dev-lang/perl to BDEPEND. Cleanup.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Thu, 15 Aug 2019 19:12:26 +0000 (19:12 +0000)
committerMike Gilbert <floppym@gentoo.org>
Fri, 16 Aug 2019 17:02:28 +0000 (13:02 -0400)
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild
net-irc/kvirc/kvirc-9999.ebuild

index a55f83dfaa4dba7d32956f3a6fab93a53133a59b..2fb31df8c0fcf3890569ca7187dac01606fea5dc 100644 (file)
@@ -1,8 +1,6 @@
 # Copyright 2009-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-# True Authors: Arfrever Frehtes Taifersar Arahesis
-
 EAPI="7"
 PYTHON_COMPAT=(python2_7)
 
@@ -34,7 +32,8 @@ KEYWORDS="amd64 ~ppc ~ppc64 x86"
 IUSE="audiofile +dbus dcc_video debug doc gsm kde +nls oss +perl +phonon profile +python spell +ssl theora webkit"
 REQUIRED_USE="audiofile? ( oss ) python? ( ${PYTHON_REQUIRED_USE} )"
 
-BDEPEND="virtual/pkgconfig
+BDEPEND="dev-lang/perl:0
+       virtual/pkgconfig
        doc? ( app-doc/doxygen )
        kde? ( kde-frameworks/extra-cmake-modules:5 )
        nls? ( sys-devel/gettext )"
@@ -106,35 +105,35 @@ src_configure() {
                -DLIB_SUFFIX=${libdir#lib}
                -DMANUAL_REVISION=${KVIRC_GIT_REVISION}
                -DMANUAL_SOURCES_DATE=${KVIRC_GIT_SOURCES_DATE//-/}
-               -DWANT_ENV_FLAGS=yes
-               -DWANT_VERBOSE=yes
-
-               -DWANT_CRYPT=yes
-               -DWANT_DCC_VOICE=yes
-               -DWANT_IPC=yes
-               -DWANT_IPV6=yes
-               -DWANT_TRANSPARENCY=yes
-
-               -DWANT_AUDIOFILE=$(usex audiofile)
-               -DWANT_DCC_VIDEO=$(usex dcc_video)
-               -DWANT_DEBUG=$(usex debug)
-               -DWANT_DOXYGEN=$(usex doc)
-               -DWANT_GETTEXT=$(usex nls)
-               -DWANT_GSM=$(usex gsm)
-               -DWANT_KDE=$(usex kde)
-               -DWANT_MEMORY_PROFILE=$(usex profile)
-               -DWANT_OGG_THEORA=$(usex theora)
-               -DWANT_OPENSSL=$(usex ssl)
-               -DWANT_OSS=$(usex oss)
-               -DWANT_PERL=$(usex perl)
-               -DWANT_PHONON=$(usex phonon)
-               -DWANT_PYTHON=$(usex python)
-               -DWANT_QTDBUS=$(usex dbus)
-               -DWANT_QTWEBKIT=$(usex webkit)
-               -DWANT_SPELLCHECKER=$(usex spell)
+               -DWANT_ENV_FLAGS=ON
+               -DWANT_VERBOSE=ON
+
+               -DWANT_CRYPT=ON
+               -DWANT_DCC_VOICE=ON
+               -DWANT_IPC=ON
+               -DWANT_IPV6=ON
+               -DWANT_TRANSPARENCY=ON
+
+               -DWANT_AUDIOFILE=$(usex audiofile ON OFF)
+               -DWANT_DCC_VIDEO=$(usex dcc_video ON OFF)
+               -DWANT_DEBUG=$(usex debug ON OFF)
+               -DWANT_DOXYGEN=$(usex doc ON OFF)
+               -DWANT_GETTEXT=$(usex nls ON OFF)
+               -DWANT_GSM=$(usex gsm ON OFF)
+               -DWANT_KDE=$(usex kde ON OFF)
+               -DWANT_MEMORY_PROFILE=$(usex profile ON OFF)
+               -DWANT_OGG_THEORA=$(usex theora ON OFF)
+               -DWANT_OPENSSL=$(usex ssl ON OFF)
+               -DWANT_OSS=$(usex oss ON OFF)
+               -DWANT_PERL=$(usex perl ON OFF)
+               -DWANT_PHONON=$(usex phonon ON OFF)
+               -DWANT_PYTHON=$(usex python ON OFF)
+               -DWANT_QTDBUS=$(usex dbus ON OFF)
+               -DWANT_QTWEBKIT=$(usex webkit ON OFF)
+               -DWANT_SPELLCHECKER=$(usex spell ON OFF)
 
                # COMPILE_SVG_SUPPORT not used in source code.
-               -DWANT_QTSVG=no
+               -DWANT_QTSVG=OFF
        )
 
        cmake-utils_src_configure
index b37c64f007b320872dacd84ca0d7918213505c74..5c27987537056e71727f75b81ccc5e93aedd131a 100644 (file)
@@ -1,8 +1,6 @@
 # Copyright 2009-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-# True Authors: Arfrever Frehtes Taifersar Arahesis
-
 EAPI="7"
 PYTHON_COMPAT=(python2_7)
 
@@ -34,7 +32,8 @@ KEYWORDS=""
 IUSE="audiofile +dbus dcc_video debug doc gsm kde +nls oss +perl +phonon profile +python spell +ssl theora webkit"
 REQUIRED_USE="audiofile? ( oss ) python? ( ${PYTHON_REQUIRED_USE} )"
 
-BDEPEND="virtual/pkgconfig
+BDEPEND="dev-lang/perl:0
+       virtual/pkgconfig
        doc? ( app-doc/doxygen )
        kde? ( kde-frameworks/extra-cmake-modules:5 )
        nls? ( sys-devel/gettext )"
@@ -106,35 +105,35 @@ src_configure() {
                -DLIB_SUFFIX=${libdir#lib}
                -DMANUAL_REVISION=${KVIRC_GIT_REVISION}
                -DMANUAL_SOURCES_DATE=${KVIRC_GIT_SOURCES_DATE//-/}
-               -DWANT_ENV_FLAGS=yes
-               -DWANT_VERBOSE=yes
-
-               -DWANT_CRYPT=yes
-               -DWANT_DCC_VOICE=yes
-               -DWANT_IPC=yes
-               -DWANT_IPV6=yes
-               -DWANT_TRANSPARENCY=yes
-
-               -DWANT_AUDIOFILE=$(usex audiofile)
-               -DWANT_DCC_VIDEO=$(usex dcc_video)
-               -DWANT_DEBUG=$(usex debug)
-               -DWANT_DOXYGEN=$(usex doc)
-               -DWANT_GETTEXT=$(usex nls)
-               -DWANT_GSM=$(usex gsm)
-               -DWANT_KDE=$(usex kde)
-               -DWANT_MEMORY_PROFILE=$(usex profile)
-               -DWANT_OGG_THEORA=$(usex theora)
-               -DWANT_OPENSSL=$(usex ssl)
-               -DWANT_OSS=$(usex oss)
-               -DWANT_PERL=$(usex perl)
-               -DWANT_PHONON=$(usex phonon)
-               -DWANT_PYTHON=$(usex python)
-               -DWANT_QTDBUS=$(usex dbus)
-               -DWANT_QTWEBKIT=$(usex webkit)
-               -DWANT_SPELLCHECKER=$(usex spell)
+               -DWANT_ENV_FLAGS=ON
+               -DWANT_VERBOSE=ON
+
+               -DWANT_CRYPT=ON
+               -DWANT_DCC_VOICE=ON
+               -DWANT_IPC=ON
+               -DWANT_IPV6=ON
+               -DWANT_TRANSPARENCY=ON
+
+               -DWANT_AUDIOFILE=$(usex audiofile ON OFF)
+               -DWANT_DCC_VIDEO=$(usex dcc_video ON OFF)
+               -DWANT_DEBUG=$(usex debug ON OFF)
+               -DWANT_DOXYGEN=$(usex doc ON OFF)
+               -DWANT_GETTEXT=$(usex nls ON OFF)
+               -DWANT_GSM=$(usex gsm ON OFF)
+               -DWANT_KDE=$(usex kde ON OFF)
+               -DWANT_MEMORY_PROFILE=$(usex profile ON OFF)
+               -DWANT_OGG_THEORA=$(usex theora ON OFF)
+               -DWANT_OPENSSL=$(usex ssl ON OFF)
+               -DWANT_OSS=$(usex oss ON OFF)
+               -DWANT_PERL=$(usex perl ON OFF)
+               -DWANT_PHONON=$(usex phonon ON OFF)
+               -DWANT_PYTHON=$(usex python ON OFF)
+               -DWANT_QTDBUS=$(usex dbus ON OFF)
+               -DWANT_QTWEBKIT=$(usex webkit ON OFF)
+               -DWANT_SPELLCHECKER=$(usex spell ON OFF)
 
                # COMPILE_SVG_SUPPORT not used in source code.
-               -DWANT_QTSVG=no
+               -DWANT_QTSVG=OFF
        )
 
        cmake-utils_src_configure