x11-plugins/wmfrog: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 14:59:39 +0000 (15:59 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:12:42 +0000 (16:12 +0100)
Closes: https://bugs.gentoo.org/707710
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild

diff --git a/x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch b/x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch
new file mode 100644 (file)
index 0000000..9d25464
--- /dev/null
@@ -0,0 +1,36 @@
+diff -Naur Src.orig/wmFrog.c Src/wmFrog.c
+--- Src.orig/wmFrog.c  2010-12-01 19:48:50.000000000 +0100
++++ Src/wmFrog.c       2020-03-01 15:54:30.428083446 +0100
+@@ -77,6 +77,12 @@
+ char* folder;
+ int needsUpdate = 1;
++Display               *display;
++Window          Root;
++Window          iconwin, win;
++int             screen; 
++int             DisplayDepth;
++
+ /*
+  *   main
+  */
+diff -Naur Src.orig/xutils.h Src/xutils.h
+--- Src.orig/xutils.h  2010-08-04 20:28:46.000000000 +0200
++++ Src/xutils.h       2020-03-01 15:54:37.027084834 +0100
+@@ -18,11 +18,11 @@
+ /*
+  *   Global variable
+  */
+-Display               *display;
+-Window          Root;
+-Window          iconwin, win;
+-int             screen; 
+-int             DisplayDepth;
++extern Display                *display;
++extern Window          Root;
++extern Window          iconwin, win;
++extern int             screen; 
++extern int             DisplayDepth;
index b3b8ab1a8a4ded502354349e5a87cedba7d579cc..fa1b1ed45fc24b8131a4c12a8e7d9494d9ae7e9a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/Src"
 
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
 DOCS=( ../{CHANGES,HINTS} )
 
 src_prepare() {